summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJorge Barroso2015-06-15 21:32:27 +0200
committerJorge Barroso2015-06-15 21:32:27 +0200
commitdd0ccbe381175a0a52ffca8fb2c6d20ac57a5785 (patch)
tree19691cbb4b732e495ac8d9c55784824d31ba1555
downloadaur-dd0ccbe381175a0a52ffca8fb2c6d20ac57a5785.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
-rw-r--r--baamanga.install18
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2928b96be328
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = baamanga
+ pkgdesc = Command-line tool to download manga from lots of websites
+ pkgver = 0.5.6
+ pkgrel = 1
+ url = https://github.com/jorge-barroso/baamanga/
+ install = baamanga.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = boost
+ depends = curlcpp-git
+ depends = boost-libs
+ provides = baamanga
+ conflicts = baamanga-git
+ source = http://sourceforge.net/projects/baamanga/files/baamanga-0.5.6.zip
+ sha512sums = 37250dcf203c6c60f2995c781a8c7969e866c51c5be00ecdf511d03f8004dc9630d4ebf5c558c336b6cdb5a45828e31fbf539a2970fd7d9de8b64779acf339ea
+
+pkgname = baamanga
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..372019d0f124
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+#!/bin/bash
+# Maintainer: Jorge Barroso <jorge.barroso.11@gmail.com>
+
+pkgname=baamanga
+pkgver=0.5.6
+pkgrel=1
+pkgdesc='Command-line tool to download manga from lots of websites'
+arch=('i686' 'x86_64')
+url="https://github.com/jorge-barroso/baamanga/"
+license=('GPL2')
+depends=('curlcpp-git'
+ 'boost-libs')
+makedepends=('boost')
+provides=(baamanga)
+conflicts=(baamanga-git)
+install=baamanga.install
+source=("http://sourceforge.net/projects/${pkgname}/files/${pkgname}-${pkgver}.zip")
+sha512sums=('37250dcf203c6c60f2995c781a8c7969e866c51c5be00ecdf511d03f8004dc9630d4ebf5c558c336b6cdb5a45828e31fbf539a2970fd7d9de8b64779acf339ea')
+
+build(){
+cd ${srcdir}/
+ autoreconf --install
+ ./configure
+ make
+}
+
+package() {
+cd ${srcdir}/
+ make DESTDIR=${pkgdir} install
+}
+
+# vim:set ts=2 sw=2 et:
+
diff --git a/baamanga.install b/baamanga.install
new file mode 100644
index 000000000000..8168330f79af
--- /dev/null
+++ b/baamanga.install
@@ -0,0 +1,18 @@
+#!/bin/bash
+
+post_install() {
+ echo ""
+ echo -e "\033[1;32m==> Any suggestion, comment, etc.? Please, visit one of the following: \033[1;34m"
+ echo -e " => https://github.com/jorge-barroso/baamanga"
+ echo -e " => https://sourceforge.net/projects/baamanga/"
+ echo -e " => http://baamanga.tk/"
+ echo ""
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}