summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBaptiste Jonglez2015-06-25 10:17:14 +0200
committerBaptiste Jonglez2015-06-25 10:22:55 +0200
commitb2f966b5163717f63ff180ae05338264f41af82f (patch)
treed2c316b70c82a43f749c717fdff962090dd987fc
downloadaur-b2f966b5163717f63ff180ae05338264f41af82f.tar.gz
Initial upload: babeld 1.6.0-1
Initial upload: babeld 1.6.0-1
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD43
-rw-r--r--babeld.conf52
-rw-r--r--babeld.service12
4 files changed, 137 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6d972d0377a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = babeld
+ pkgdesc = A loop-avoiding distance-vector routing protocol
+ pkgver = 1.6.0
+ pkgrel = 1
+ url = http://www.pps.univ-paris-diderot.fr/~jch/software/babel/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = glibc
+ optdepends = ahcpd: for autoconfiguration of addresses and other informations
+ backup = etc/babeld.conf
+ source = http://www.pps.univ-paris-diderot.fr/~jch/software/files/babeld-1.6.0.tar.gz
+ source = http://www.pps.univ-paris-diderot.fr/~jch/software/files/babeld-1.6.0.tar.gz.asc
+ source = babeld.conf
+ source = babeld.service
+ md5sums = b0602a6124ddafb37225bd1a2d8abb13
+ md5sums = SKIP
+ md5sums = 2b009a8f97eb038fbd7e73c5dd341bf5
+ md5sums = d6407e493f79aad1887394639ef5d50e
+ sha1sums = 86f62da29a618aa114a1e5079aa15699d10a7a5f
+ sha1sums = SKIP
+ sha1sums = 119c7fa6ec86d63b0bd59f395ac6651842ba94bb
+ sha1sums = 864840cfafeeb3f29c0f91421bc210a8c1f4b245
+ sha256sums = 26982e741dabb14b444c5bda827eee9c002aa285d942b36b7e5f36053a34d308
+ sha256sums = SKIP
+ sha256sums = 6bb17ade33e6fa34a5f0a181b1f2135c396108d40ce1278d9b3ebd68580bbf44
+ sha256sums = fde7554e0d8a200d99b0766bd0ce23cbd7d14593c43d96de158e2fa2c379c1c5
+
+pkgname = babeld
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b57db167ffd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Baptiste Jonglez <baptiste--aur at jonglez dot org>
+# Contributor: Yann Lopez <arch at lonewulf dot net>
+pkgname=babeld
+pkgver=1.6.0
+pkgrel=1
+pkgdesc="A loop-avoiding distance-vector routing protocol"
+arch=('i686' 'x86_64')
+url="http://www.pps.univ-paris-diderot.fr/~jch/software/babel/"
+license=('MIT')
+depends=('glibc')
+optdepends=('ahcpd: for autoconfiguration of addresses and other informations')
+backup=('etc/babeld.conf')
+source=("http://www.pps.univ-paris-diderot.fr/~jch/software/files/$pkgname-$pkgver.tar.gz"
+ "http://www.pps.univ-paris-diderot.fr/~jch/software/files/$pkgname-$pkgver.tar.gz.asc"
+ "babeld.conf"
+ "babeld.service")
+md5sums=('b0602a6124ddafb37225bd1a2d8abb13'
+ 'SKIP'
+ '2b009a8f97eb038fbd7e73c5dd341bf5'
+ 'd6407e493f79aad1887394639ef5d50e')
+sha1sums=('86f62da29a618aa114a1e5079aa15699d10a7a5f'
+ 'SKIP'
+ '119c7fa6ec86d63b0bd59f395ac6651842ba94bb'
+ '864840cfafeeb3f29c0f91421bc210a8c1f4b245')
+sha256sums=('26982e741dabb14b444c5bda827eee9c002aa285d942b36b7e5f36053a34d308'
+ 'SKIP'
+ '6bb17ade33e6fa34a5f0a181b1f2135c396108d40ce1278d9b3ebd68580bbf44'
+ 'fde7554e0d8a200d99b0766bd0ce23cbd7d14593c43d96de158e2fa2c379c1c5')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make PREFIX="/usr"
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make PREFIX="/usr" TARGET="$pkgdir" install
+
+ install -Dm644 ../babeld.conf "${pkgdir}"/etc/babeld.conf
+ install -Dm644 ../babeld.service "${pkgdir}"/usr/lib/systemd/system/babeld.service
+}
diff --git a/babeld.conf b/babeld.conf
new file mode 100644
index 000000000000..278297ef13c1
--- /dev/null
+++ b/babeld.conf
@@ -0,0 +1,52 @@
+# Configuration for babeld. See the man page babeld(8) for
+# details on the configuration format.
+
+# Works on Linux > 3.11
+ipv6-subtrees true
+
+# You must provide at least one interface for babeld to operate on.
+#interface eth0
+#interface wlan0
+
+# Global options you might want to set. There are many more, see the man page.
+#debug 1
+#local-port 33123
+#diversity true
+#random-id true
+
+# Per-interface configuration. Note that each interface referenced here
+# will be used by babeld.
+#interface eth1 rxcost 10
+#interface tun0 faraway true
+#interface wlan0 hello-interval 1
+
+# Since 1.4.2, you can also specify defaults for interface parameters, which
+# will be used for all interfaces except specified otherwise (see above).
+#default rxcost 42
+#default hello-interval 5
+
+# Since 1.5.0, you can use the RTT-based metric, most useful for a network
+# with tunnels (overlay network).
+#default enable-timestamps true
+#interface tun0 max-rtt-penalty 150
+#interface tun0 rtt-max 100
+
+
+# Filtering rules.
+
+# Only accept routes included in a specific prefix.
+#in ip 192.168.42.0/24 allow
+#in ip 2001:db8:cafe:cafe::/64 allow
+#in deny
+
+# Only redistribute addresses from a given prefix, to avoid redistributing
+# all local addresses
+#redistribute ip 192.168.1.0/24 local allow
+#redistribute ip 2001:db8:cafe:cafe::/64 local allow
+#redistribute local deny
+
+# Redistribute a default route obtained otherwise (here, through DHCP or
+# configured statically).
+# Note that babeld ignores kernel routes with proto 3 (boot) by default.
+#redistribute proto 3 ip 0.0.0.0/0 eq 0 metric 50
+#redistribute proto 3 ip ::/0 eq 0 metric 50
diff --git a/babeld.service b/babeld.service
new file mode 100644
index 000000000000..bad1aff9327e
--- /dev/null
+++ b/babeld.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Babel routing daemon
+Documentation=man:babeld(8) http://www.pps.univ-paris-diderot.fr/~jch/software/babel/
+After=network.target
+
+[Service]
+Type=forking
+ExecStart=/usr/bin/babeld -D
+PIDFile=/var/run/babeld.pid
+
+[Install]
+WantedBy=multi-user.target