summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorworkonfire2021-05-06 12:15:37 +0200
committerworkonfire2021-05-06 12:15:37 +0200
commit40a0752eac4407c812fc368b6d2aac6d195aa5f2 (patch)
tree6902bcea5509a55ef51ae4f995259795606a0afd
downloadaur-40a0752eac4407c812fc368b6d2aac6d195aa5f2.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD25
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3bde5a6ebdd9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = babi
+ pkgdesc = A text editor, eventually...
+ pkgver = 0.0.21
+ pkgrel = 1
+ url = https://github.com/asottile/babi
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-onigurumacffi
+ depends = babi-grammars
+ depends = python-identify
+ source = https://github.com/asottile/babi/archive/v0.0.21.tar.gz
+ md5sums = 3e9721bc9a5c89c6e4c2812649eec995
+
+pkgname = babi
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b1d7bac67692
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+# Tar files
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.zst
+
+# Makepkg trash
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4213ab528105
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: workonfire <kolucki62@gmail.com>
+
+pkgname=babi
+pkgver=0.0.21
+pkgrel=1
+pkgdesc="A text editor, eventually..."
+arch=('any')
+url="https://github.com/asottile/babi"
+license=('MIT')
+depends=('python-onigurumacffi' 'babi-grammars' 'python-identify')
+makedepends=('python-setuptools')
+source=("$url/archive/v$pkgver.tar.gz")
+md5sums=('3e9721bc9a5c89c6e4c2812649eec995')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+