summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLetu Ren2022-04-06 23:30:23 +0800
committerLetu Ren2022-04-06 23:30:23 +0800
commit46f0f3b33595a9e634e47295c0dc468e3227a736 (patch)
tree46f0bb8a052f568d64b2b2dbbe64528234d6f05e
parentdf4f42e21f1b8d0f8d8014e474c9b3601b8861a0 (diff)
downloadaur-46f0f3b33595a9e634e47295c0dc468e3227a736.tar.gz
upgrade to 1.0.5
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1e6c57cfb92..93271b327276 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = babi
pkgdesc = A text editor, eventually...
- pkgver = 0.0.21
- pkgrel = 2
+ pkgver = 1.5.0
+ pkgrel = 1
url = https://github.com/asottile/babi
arch = any
license = MIT
makedepends = python-setuptools
- depends = python-onigurumacffi
+ depends = python-onigurumacffi>=0.0.18
depends = babi-grammars
depends = python-identify
provides = babi
conflicts = babi
conflicts = babi-git
- source = https://github.com/asottile/babi/archive/v0.0.21.tar.gz
- md5sums = 3e9721bc9a5c89c6e4c2812649eec995
+ source = https://files.pythonhosted.org/packages/source/b/babi/babi-1.5.0.tar.gz
+ sha256sums = f59067af07c0abf16246ded59b525af9d022cfdba4173f3680ff8df61a9f359f
pkgname = babi
-
diff --git a/PKGBUILD b/PKGBUILD
index 7fce9942f571..a554c4fcd266 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,27 @@
-# Maintainer: workonfire <kolucki62@gmail.com>
+# Maintainer: Letu Ren <fantasquex at gmail dot com>
+# Contributor: workonfire <kolucki62@gmail.com>
pkgname=babi
-pkgver=0.0.21
-pkgrel=2
+pkgver=1.5.0
+pkgrel=1
pkgdesc="A text editor, eventually..."
arch=('any')
url="https://github.com/asottile/babi"
license=('MIT')
-depends=('python-onigurumacffi' 'babi-grammars' 'python-identify')
+depends=('python-onigurumacffi>=0.0.18' 'babi-grammars' 'python-identify')
makedepends=('python-setuptools')
provides=('babi')
conflicts=('babi' 'babi-git')
-source=("$url/archive/v$pkgver.tar.gz")
-md5sums=('3e9721bc9a5c89c6e4c2812649eec995')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('f59067af07c0abf16246ded59b525af9d022cfdba4173f3680ff8df61a9f359f')
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "${pkgname}-${pkgver}"
python setup.py build
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "${pkgname}-${pkgver}"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}