summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorworkonfire2021-05-06 16:12:29 +0200
committerworkonfire2021-05-06 16:12:29 +0200
commit3d349ecaa7e7054c037575dab6c7c11692766bfc (patch)
treef2f39bd0bd64b774c6e157c0fcb3669dc5c4b049
downloadaur-3d349ecaa7e7054c037575dab6c7c11692766bfc.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD33
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fef3275d9a29
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = babi-git
+ pkgdesc = A text editor, eventually...
+ pkgver = v0.0.21.r25.g2c200b9
+ pkgrel = 1
+ url = https://github.com/asottile/babi
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-onigurumacffi
+ depends = babi-grammars
+ depends = python-identify
+ provides = babi
+ conflicts = babi
+ conflicts = babi-git
+ source = babi-git::git+https://github.com/asottile/babi.git
+ sha256sums = SKIP
+
+pkgname = babi-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b1d7bac67692
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+# Tar files
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.zst
+
+# Makepkg trash
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f449d30ad1f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: workonfire <kolucki62@gmail.com>
+
+_pkgname=babi
+pkgname=$_pkgname-git
+pkgver=v0.0.21.r25.g2c200b9
+pkgrel=1
+pkgdesc="A text editor, eventually..."
+arch=('any')
+url="https://github.com/asottile/babi"
+license=('MIT')
+depends=('python-onigurumacffi' 'babi-grammars' 'python-identify')
+makedepends=('python-setuptools')
+provides=('babi')
+conflicts=('babi' 'babi-git')
+source=("${pkgname}"::git+https://github.com/asottile/babi.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+