summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2019-08-23 10:04:06 +0200
committerbartus2019-08-23 10:04:06 +0200
commita89006a691e9d509d045ac62bfeecaa2116f2a81 (patch)
tree309165954da946a1181831fb8fbd3b3470f8cda4
parentc6b3cd57804b77be12bffadc66386fedf80f85b1 (diff)
downloadaur-babl-qfix-git.tar.gz
Fix pkgver() again :/
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd64c058e0e4..703375f8a42b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = babl-qfix-git
pkgdesc = babl is a dynamic, any to any, pixel format translation library.
- pkgver = 0.1.71.r27.5801e2b
+ pkgver = 0.1.71.r1597.cff46ae
pkgrel = 1
url = https://www.gegl.org/babl
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = babl-qfix-git
makedepends = lcms2
depends = glibc
depends = gobject-introspection
- provides = babl=0.1.71.r27.5801e2b
+ provides = babl=0.1.71.r1597.cff46ae
conflicts = babl
options = !libtool
source = git+https://gitlab.gnome.org/GNOME/babl
diff --git a/PKGBUILD b/PKGBUILD
index 6c68931006dd..c3936489f845 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname=babl
pkgname="${_pkgname}-qfix-git"
-pkgver=0.1.71.r27.5801e2b
+pkgver=0.1.71.r1597.cff46ae
pkgrel=1
pkgdesc="babl is a dynamic, any to any, pixel format translation library."
arch=('x86_64')
@@ -31,10 +31,11 @@ prepare() {
}
pkgver() {
+ cd ${srcdir}/${_pkgname}
printf "%d.%d.%d.r%s.%s" \
- $(grep -Po '^#define BABL_MAJOR_VERSION \K[0-9]*$' build/config.h) \
- $(grep -Po '^#define BABL_MINOR_VERSION \K[0-9]*$' build/config.h) \
- $(grep -Po '^#define BABL_MICRO_VERSION \K[0-9]*$' build/config.h) \
+ $(grep -Po '^#define BABL_MAJOR_VERSION \K[0-9]*$' ${srcdir}/build/config.h) \
+ $(grep -Po '^#define BABL_MINOR_VERSION \K[0-9]*$' ${srcdir}/build/config.h) \
+ $(grep -Po '^#define BABL_MICRO_VERSION \K[0-9]*$' ${srcdir}/build/config.h) \
$(git rev-list --count HEAD) \
$(git rev-parse --short HEAD)
}