summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Manna2022-09-10 16:16:38 -0500
committerKyle Manna2022-09-10 16:16:38 -0500
commit363448add3f8fe578ca0f77affb4f9b755fbf3b0 (patch)
treeba0ee3413a70d53b86b1716bdd3293c7423d1708
parent7488fdb2dc02a2340f860a89de9c2731a1202730 (diff)
downloadaur-363448add3f8fe578ca0f77affb4f9b755fbf3b0.tar.gz
release: backblaze-b2 v3.5.0
* Bump release. * These pinned dependencies are still annoying.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD11
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70d87bda2752..102cf4e9a2ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = backblaze-b2
pkgdesc = Backblaze B2 Command Line Client
- pkgver = 3.4.0
+ pkgver = 3.5.0
pkgrel = 1
url = https://github.com/Backblaze/B2_Command_Line_Tool
arch = any
@@ -10,12 +10,13 @@ pkgbase = backblaze-b2
makedepends = python-setuptools-scm
depends = python
depends = python-arrow>=0.8.0
- depends = python-b2sdk<=1.17.0
- depends = python-b2sdk>=1.16.0
- depends = python-docutils>=0.16
+ depends = python-b2sdk<=1.18.0
+ depends = python-b2sdk>=1.17.3
+ depends = python-docutils>=0.19
depends = python-class-registry=3.0.5
depends = python-rst2ansi=0.1.5
- source = https://github.com/Backblaze/B2_Command_Line_Tool/releases/download/v3.4.0/b2-3.4.0.tar.gz
- sha256sums = c7602998cf81e760c42481914d48f5ab8a38f3d4576bbb91dfee39576549c9e6
+ depends = python-tabulate>=0.8.10
+ source = https://github.com/Backblaze/B2_Command_Line_Tool/releases/download/v3.5.0/b2-3.5.0.tar.gz
+ sha256sums = bf2a84c6e96c574c038a32e8b4f3b74403a4f68e277b456aef82892a1481aefa
pkgname = backblaze-b2
diff --git a/PKGBUILD b/PKGBUILD
index 66b51fa272ff..cf1573395747 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,18 @@
pkgname=backblaze-b2
_pkgname=b2
-pkgver=3.4.0
+pkgver=3.5.0
pkgrel=1
pkgdesc='Backblaze B2 Command Line Client'
url='https://github.com/Backblaze/B2_Command_Line_Tool'
depends=('python'
'python-arrow>=0.8.0'
- 'python-b2sdk<=1.17.0'
- 'python-b2sdk>=1.16.0'
- 'python-docutils>=0.16'
+ 'python-b2sdk<=1.18.0'
+ 'python-b2sdk>=1.17.3'
+ 'python-docutils>=0.19'
'python-class-registry=3.0.5'
'python-rst2ansi=0.1.5'
+ 'python-tabulate>=0.8.10'
)
makedepends=('python-pip'
'python-setuptools'
@@ -24,7 +25,7 @@ license=('MIT')
arch=('any')
source=("https://github.com/Backblaze/B2_Command_Line_Tool/releases/download/v${pkgver}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('c7602998cf81e760c42481914d48f5ab8a38f3d4576bbb91dfee39576549c9e6')
+sha256sums=('bf2a84c6e96c574c038a32e8b4f3b74403a4f68e277b456aef82892a1481aefa')
build() {
cd ${srcdir}/${_pkgname}-${pkgver}