summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Manna2018-07-15 18:39:57 -0700
committerKyle Manna2018-07-15 18:39:57 -0700
commit38884070a2290ebf86a5d7164eb7ec6717bfdff5 (patch)
tree27465e060dc2c714f237acc614e0d9dd6b78de1b
parente745b8ffe8f90838fe4931d92ab5f91cdee394df (diff)
downloadaur-38884070a2290ebf86a5d7164eb7ec6717bfdff5.tar.gz
pkgrel: Tweak python2-arrow dep
* Seems there are issues with python2-arrow and python-2.6 See https://github.com/crsmithdev/arrow/issues/517
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10141b9e6bdc..366eb1380a90 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
# Generated by mksrcinfo v8
-# Sun Jul 15 22:10:07 UTC 2018
+# Mon Jul 16 01:39:24 UTC 2018
pkgbase = backblaze-b2
pkgdesc = Backblaze B2 Command Line Client
pkgver = 1.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.backblaze.com/b2/cloud-storage.html
arch = any
license = MIT
- depends = python2
+ depends = python2>=2.7
depends = python2-arrow>=0.8.0
depends = python2-logfury>=0.1.2
depends = python2-requests>=2.9.1
diff --git a/PKGBUILD b/PKGBUILD
index 5d6539073c55..6e1ac243f6fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Kyle Manna <kyle[at]kylemanna[d0t]com>
pkgname=backblaze-b2
pkgver=1.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="Backblaze B2 Command Line Client"
url="https://www.backblaze.com/b2/cloud-storage.html"
-depends=('python2'
+depends=('python2>=2.7'
'python2-arrow>=0.8.0'
'python2-logfury>=0.1.2'
'python2-requests>=2.9.1'
@@ -23,6 +23,7 @@ sha512sums=('24b1845842318f93657321454ff0e292a4912ac84986b84a502800482b00ea6aabf
build() {
cd ${srcdir}/B2_Command_Line_Tool-${pkgver}
+ sed -i -e 's:^\(arrow.*\),<0.12.1:\1:' requirements.txt
python2 setup.py build
}