summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Manna2021-04-03 16:17:11 -0700
committerKyle Manna2021-04-03 16:18:20 -0700
commit8b77e84ef45c88748455a229805e060e069d1b7e (patch)
treecb1e52a2ccdeea61c209112bdec2b8970eda1d04
parentf22511ff1ed3beb3c42c1877753d8f448022bf9b (diff)
downloadaur-8b77e84ef45c88748455a229805e060e069d1b7e.tar.gz
release: backblaze-b2 v2.3.0-1
* Package has been cleaned-up by upstream. Awesome.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD16
2 files changed, 17 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc56b4dcd157..0b5a5383682b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
pkgbase = backblaze-b2
pkgdesc = Backblaze B2 Command Line Client
- pkgver = 2.1.0
+ pkgver = 2.3.0
pkgrel = 1
url = https://github.com/Backblaze/B2_Command_Line_Tool
arch = any
license = MIT
depends = python
+ depends = python-arrow>=0.8.0
depends = python-b2sdk>=1.0.0
+ depends = python-b2sdk<2.0.0
depends = python-tqdm>=4.5.0
depends = python-class-registry=3.0.5
- source = https://github.com/Backblaze/B2_Command_Line_Tool/archive/v2.1.0.tar.gz
- sha512sums = 8dcf2f6bb244e67c0bd3c91b5984d62f37d553bb018a87c81baca49cb2ca0d7f743c64695189829216206976b1e7cb5deb9776c94c8bda2d3d9f8deccb33685a
+ depends = python-rst2ansi=0.1.5
+ source = https://files.pythonhosted.org/packages/source/b/b2/b2-2.3.0.tar.gz
+ sha256sums = 9b3fa855e564815ddbb6e7815bd9b0b761a41f70d49e5c0d6785639f9217c122
pkgname = backblaze-b2
diff --git a/PKGBUILD b/PKGBUILD
index 3114e52754ac..1cb185925f68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,33 @@
# Maintainer: Kyle Manna <kyle[at]kylemanna[d0t]com>
pkgname=backblaze-b2
-_pkgname=B2_Command_Line_Tool
-pkgver=2.1.0
+_pkgname=b2
+pkgver=2.3.0
pkgrel=1
pkgdesc="Backblaze B2 Command Line Client"
url='https://github.com/Backblaze/B2_Command_Line_Tool'
depends=('python'
+ 'python-arrow>=0.8.0'
'python-b2sdk>=1.0.0'
+ 'python-b2sdk<2.0.0'
'python-tqdm>=4.5.0'
'python-class-registry=3.0.5'
+ 'python-rst2ansi=0.1.5'
)
-optdepends=()
+
# MIT or Creative Commons: https://www.backblaze.com/using_b2_code.html
license=('MIT')
arch=('any')
-source=("https://github.com/Backblaze/${_pkgname}/archive/v${pkgver}.tar.gz")
-sha512sums=('8dcf2f6bb244e67c0bd3c91b5984d62f37d553bb018a87c81baca49cb2ca0d7f743c64695189829216206976b1e7cb5deb9776c94c8bda2d3d9f8deccb33685a')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('9b3fa855e564815ddbb6e7815bd9b0b761a41f70d49e5c0d6785639f9217c122')
build() {
cd ${srcdir}/${_pkgname}-${pkgver}
+ # This requriement seems overly complex, losen
+ sed -i -e 's:\(arrow>=.*\),.*:\1:' requirements.txt
+
python setup.py build
}