summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Manna2023-02-13 18:12:48 -0600
committerKyle Manna2023-02-13 18:12:48 -0600
commitcbf09e2350dea09b28113fddac8119d96e283227 (patch)
tree8e29c4eb65563f2252ec2cc5612a054576bcfd7e
parent3e3bd160c3e889d38e6f90187228e50e5239878d (diff)
downloadaur-cbf09e2350dea09b28113fddac8119d96e283227.tar.gz
release: backblaze-b2 v3.7.1
* Bump release. * These pinned dependencies are still annoying. * Fix uu-install issue.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9b07b8f0c2c..1851777a6e4a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = backblaze-b2
pkgdesc = Backblaze B2 Command Line Client
- pkgver = 3.6.0
+ pkgver = 3.7.1
pkgrel = 1
url = https://github.com/Backblaze/B2_Command_Line_Tool
arch = any
@@ -12,10 +12,10 @@ pkgbase = backblaze-b2
depends = python-arrow>=1.0.2
depends = python-b2sdk>=1.18.0
depends = python-docutils>=0.19
- depends = python-class-registry=3.0.5
+ depends = python-class-registry>=4.0.5
depends = python-rst2ansi=0.1.5
depends = python-tabulate>=0.8.10
- source = https://github.com/Backblaze/B2_Command_Line_Tool/releases/download/v3.6.0/b2-3.6.0.tar.gz
- sha256sums = a879e751348b635ca772a2231be20c2e835abaf830534e2ab2f1fb75967c0252
+ source = https://github.com/Backblaze/B2_Command_Line_Tool/releases/download/v3.7.1/b2-3.7.1.tar.gz
+ sha256sums = 68b10511447576c3286159f5fe66ee180dddb4547dcb4a423fa964454720019f
pkgname = backblaze-b2
diff --git a/PKGBUILD b/PKGBUILD
index 9f6d3837ea3b..6c1835e3ef81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=backblaze-b2
_pkgname=b2
-pkgver=3.6.0
+pkgver=3.7.1
pkgrel=1
pkgdesc='Backblaze B2 Command Line Client'
url='https://github.com/Backblaze/B2_Command_Line_Tool'
@@ -10,7 +10,7 @@ depends=('python'
'python-arrow>=1.0.2'
'python-b2sdk>=1.18.0'
'python-docutils>=0.19'
- 'python-class-registry=3.0.5'
+ 'python-class-registry>=4.0.5'
'python-rst2ansi=0.1.5'
'python-tabulate>=0.8.10'
)
@@ -24,7 +24,7 @@ license=('MIT')
arch=('any')
source=("https://github.com/Backblaze/B2_Command_Line_Tool/releases/download/v${pkgver}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('a879e751348b635ca772a2231be20c2e835abaf830534e2ab2f1fb75967c0252')
+sha256sums=('68b10511447576c3286159f5fe66ee180dddb4547dcb4a423fa964454720019f')
build() {
cd ${srcdir}/${_pkgname}-${pkgver}
@@ -41,7 +41,10 @@ package() {
cd ${srcdir}/${_pkgname}-${pkgver}
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ # uu-coreutils messes up the directory permissions (644, expect 755)
+ #install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ install LICENSE "$pkgdir/usr/share/licenses/$pkgname"
# https://wiki.archlinux.org/index.php/Python_package_guidelines
local site_packages=$(python -c 'import site; print(site.getsitepackages()[0])')