summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Manna2020-07-21 22:36:26 -0700
committerKyle Manna2020-07-21 22:36:26 -0700
commite3d9b7a79217ad043174ba2771a2a95e7f89d6fc (patch)
treeae0f8b318d38a09f40074cd8bffaefe88fc38b0a
parentaddb85757321a0e21095c591b8ddfb6c8b710e57 (diff)
downloadaur-e3d9b7a79217ad043174ba2771a2a95e7f89d6fc.tar.gz
release: backblaze-b2 v2.0.2-1
* Follow upstream * Backblaze SDK is finally ready.
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD13
3 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d29dea958d5..95df05bce85e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = backblaze-b2
pkgdesc = Backblaze B2 Command Line Client
- pkgver = 1.4.2
+ pkgver = 2.0.2
pkgrel = 1
- url = https://www.backblaze.com/b2/cloud-storage.html
+ url = https://github.com/Backblaze/B2_Command_Line_Tool
arch = any
license = MIT
depends = python
- depends = python-tqdm>=4.5.0
+ depends = python-b2sdk>=1.0.0
depends = python-six>=1.10
- depends = python-b2sdk>=0.1.8
- source = https://github.com/Backblaze/B2_Command_Line_Tool/archive/v1.4.2.tar.gz
- sha512sums = 7ac6108fe3130c7fd465cf7e20f881efe8a9c85655c4dff4241c2b2861ee7543c7a8ddd195b974d190556595e857ed71f2cb1bdd6ca9a4567d336bd90c7ae2b2
+ depends = python-tqdm>=4.5.0
+ source = https://github.com/Backblaze/B2_Command_Line_Tool/archive/v2.0.2.tar.gz
+ sha512sums = 0e0ebf698f49de00cb530bd0928855058fc6d1f4aaeb0b7b1bbea475e6e3f2add8c7acd9a75baf348907646eedc199b9729e1777bfb4a4e63952782a74c749dc
pkgname = backblaze-b2
diff --git a/.gitignore b/.gitignore
index e3986ba1b1b8..dad3253e1b2f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,6 @@
*.xz
*.tar.gz
+*.tar.zst
/src
/pkg
/b2
diff --git a/PKGBUILD b/PKGBUILD
index 2fc9fd313045..fc4a3523df2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,15 @@
pkgname=backblaze-b2
_pkgname=B2_Command_Line_Tool
-pkgver=1.4.2
+pkgver=2.0.2
pkgrel=1
pkgdesc="Backblaze B2 Command Line Client"
-url="https://www.backblaze.com/b2/cloud-storage.html"
+url='https://github.com/Backblaze/B2_Command_Line_Tool'
depends=('python'
- 'python-tqdm>=4.5.0'
+ 'python-b2sdk>=1.0.0'
'python-six>=1.10'
- 'python-b2sdk>=0.1.8'
+ 'python-tqdm>=4.5.0'
+ 'python-logfury'
)
optdepends=()
# MIT or Creative Commons: https://www.backblaze.com/using_b2_code.html
@@ -17,11 +18,11 @@ license=('MIT')
arch=('any')
source=("https://github.com/Backblaze/${_pkgname}/archive/v${pkgver}.tar.gz")
-sha512sums=('7ac6108fe3130c7fd465cf7e20f881efe8a9c85655c4dff4241c2b2861ee7543c7a8ddd195b974d190556595e857ed71f2cb1bdd6ca9a4567d336bd90c7ae2b2')
+sha512sums=('0e0ebf698f49de00cb530bd0928855058fc6d1f4aaeb0b7b1bbea475e6e3f2add8c7acd9a75baf348907646eedc199b9729e1777bfb4a4e63952782a74c749dc')
build() {
cd ${srcdir}/${_pkgname}-${pkgver}
- sed -i -e 's:^\(arrow.*\),<0.12.1:\1:' requirements.txt
+
python setup.py build
}