summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Manna2020-12-06 07:58:59 -0800
committerKyle Manna2020-12-06 08:13:16 -0800
commitf22511ff1ed3beb3c42c1877753d8f448022bf9b (patch)
tree7bb183ff934fc5c7c1b9781b7b57c7d969cd6984
parent3e3a7f52f184fe33b1485a65c6948c3d8c519a2f (diff)
downloadaur-f22511ff1ed3beb3c42c1877753d8f448022bf9b.tar.gz
release: backblaze-b2 v2.1.0-1
* Follow upstream. * Install LICENSE properly. * Improve test clean-up.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a778d36e6b4e..fc56b4dcd157 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
pkgbase = backblaze-b2
pkgdesc = Backblaze B2 Command Line Client
- pkgver = 2.0.2
- pkgrel = 2
+ pkgver = 2.1.0
+ pkgrel = 1
url = https://github.com/Backblaze/B2_Command_Line_Tool
arch = any
license = MIT
depends = python
depends = python-b2sdk>=1.0.0
- depends = python-six>=1.10
depends = python-tqdm>=4.5.0
- depends = python-logfury
- depends = python-class-registry
- source = https://github.com/Backblaze/B2_Command_Line_Tool/archive/v2.0.2.tar.gz
- sha512sums = 0e0ebf698f49de00cb530bd0928855058fc6d1f4aaeb0b7b1bbea475e6e3f2add8c7acd9a75baf348907646eedc199b9729e1777bfb4a4e63952782a74c749dc
+ depends = python-class-registry=3.0.5
+ source = https://github.com/Backblaze/B2_Command_Line_Tool/archive/v2.1.0.tar.gz
+ sha512sums = 8dcf2f6bb244e67c0bd3c91b5984d62f37d553bb018a87c81baca49cb2ca0d7f743c64695189829216206976b1e7cb5deb9776c94c8bda2d3d9f8deccb33685a
pkgname = backblaze-b2
diff --git a/PKGBUILD b/PKGBUILD
index 39539a5b43f4..3114e52754ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,14 @@
pkgname=backblaze-b2
_pkgname=B2_Command_Line_Tool
-pkgver=2.0.2
-pkgrel=2
+pkgver=2.1.0
+pkgrel=1
pkgdesc="Backblaze B2 Command Line Client"
url='https://github.com/Backblaze/B2_Command_Line_Tool'
depends=('python'
'python-b2sdk>=1.0.0'
- 'python-six>=1.10'
'python-tqdm>=4.5.0'
- 'python-logfury'
- 'python-class-registry'
+ 'python-class-registry=3.0.5'
)
optdepends=()
# MIT or Creative Commons: https://www.backblaze.com/using_b2_code.html
@@ -19,7 +17,7 @@ license=('MIT')
arch=('any')
source=("https://github.com/Backblaze/${_pkgname}/archive/v${pkgver}.tar.gz")
-sha512sums=('0e0ebf698f49de00cb530bd0928855058fc6d1f4aaeb0b7b1bbea475e6e3f2add8c7acd9a75baf348907646eedc199b9729e1777bfb4a4e63952782a74c749dc')
+sha512sums=('8dcf2f6bb244e67c0bd3c91b5984d62f37d553bb018a87c81baca49cb2ca0d7f743c64695189829216206976b1e7cb5deb9776c94c8bda2d3d9f8deccb33685a')
build() {
cd ${srcdir}/${_pkgname}-${pkgver}
@@ -31,8 +29,11 @@ package() {
cd ${srcdir}/${_pkgname}-${pkgver}
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
# https://wiki.archlinux.org/index.php/Python_package_guidelines
- rm -rf ${pkgdir}/usr/lib/python*/site-packages/tests/
+ local site_packages=$(python -c 'import site; print(site.getsitepackages()[0])')
+ rm -rf "${pkgdir}${site_packages}/test"
# Installed to backblaze-b2 because the Boost pkg installs /usr/bin/b2
mv ${pkgdir}/usr/bin/b2 ${pkgdir}/usr/bin/backblaze-b2