summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Manna2016-01-29 14:00:15 -0800
committerKyle Manna2016-01-29 14:04:23 -0800
commitfb9fc4a465a033de7cccbaef0b8740bc75995116 (patch)
treef688cb7757e3b113a414116283f3c5279b81e7b4
parent8f27b4bf7616f48aeb950ee664c1d1fed722a3c0 (diff)
downloadaur-fb9fc4a465a033de7cccbaef0b8740bc75995116.tar.gz
release: backblaze-b2 v0.3.10-3
* Switch to Github upstream release tarball for sanity * Depend on python2 explicitly
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7cd56cce979a..f663189c57b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
# Generated by mksrcinfo v8
-# Tue Jan 19 16:37:02 UTC 2016
+# Fri Jan 29 22:03:42 UTC 2016
pkgbase = backblaze-b2
pkgdesc = Backblaze B2 Command Line Client
pkgver = 0.3.10
- pkgrel = 2
+ pkgrel = 3
url = https://www.backblaze.com/b2/cloud-storage.html
arch = any
license = MIT
- depends = python
- source = https://docs.backblaze.com/public/b2_src_code_bundles/b2
- sha512sums = 9abdd9c1009d81b002f39746e18b8a53fd13f241aead2cb9aadf143904defaf64e9571b8639488b3f302d5ba3cd6bb370a23a9a59760f1281245c82165a32d06
+ depends = python2
+ source = https://github.com/Backblaze/B2_Command_Line_Tool/archive/v0.3.10.tar.gz
+ sha512sums = 1148714390c0d578bb8a674704aa87b3e00e367481bb8584c6f16d2b16820b4f8b5f46836572c431f6eae2b1eb3c688467288b4e1c3422f3d8d9ec688919c5bc
pkgname = backblaze-b2
diff --git a/PKGBUILD b/PKGBUILD
index 04e4036748bf..5f574155d8a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,27 @@
# Maintainer: Kyle Manna <kyle[at]kylemanna[d0t]com>
pkgname=backblaze-b2
pkgver=0.3.10
-pkgrel=2
+pkgrel=3
pkgdesc="Backblaze B2 Command Line Client"
url="https://www.backblaze.com/b2/cloud-storage.html"
-depends=('python')
+depends=('python2')
optdepends=()
# MIT or Creative Commons: https://www.backblaze.com/using_b2_code.html
license=('MIT')
arch=('any')
# Need a better source URL at some point
-source=("https://docs.backblaze.com/public/b2_src_code_bundles/b2")
-sha512sums=('9abdd9c1009d81b002f39746e18b8a53fd13f241aead2cb9aadf143904defaf64e9571b8639488b3f302d5ba3cd6bb370a23a9a59760f1281245c82165a32d06')
+source=("https://github.com/Backblaze/B2_Command_Line_Tool/archive/v0.3.10.tar.gz")
+sha512sums=('1148714390c0d578bb8a674704aa87b3e00e367481bb8584c6f16d2b16820b4f8b5f46836572c431f6eae2b1eb3c688467288b4e1c3422f3d8d9ec688919c5bc')
package() {
+ cd ${srcdir}/B2_Command_Line_Tool-${pkgver}
+
# Hardcode python2, converting is frivilous
# I started to convert it but after 2to3, decode() I gave up
sed -ie 's:^#!/usr/bin/env\s\+python$:#!/usr/bin/env python2:' b2
# Installed to backblaze-b2 because the Boost pkg installs /usr/bin/b2
- install -D ${srcdir}/b2 ${pkgdir}/usr/bin/backblaze-b2
+ install -D b2 ${pkgdir}/usr/bin/backblaze-b2
}