summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchrisx82021-11-04 11:53:49 -0400
committerchrisx82021-11-04 11:53:49 -0400
commitbf21c95b13f470a437000f5030eb7c8dd93d7e38 (patch)
tree36cf826461d9ea62f5d41d20063c081b5f1ddb8b
downloadaur-bf21c95b13f470a437000f5030eb7c8dd93d7e38.tar.gz
initial release v3.1.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e3787c88df2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = backblaze-b2-bin
+ pkgdesc = Backblaze B2 Command Line Client
+ pkgver = 3.1.0
+ pkgrel = 1
+ url = https://github.com/Backblaze/B2_Command_Line_Tool
+ arch = x86_64
+ license = MIT
+ provides = backblaze-b2
+ conflicts = backblaze-b2
+ source_x86_64 = b2-linux::https://github.com/Backblaze/B2_Command_Line_Tool/releases/download/v3.1.0/b2-linux
+ sha256sums_x86_64 = 4b655d6d468586e07123eada3c5efdfb7ea878e19c7dea0ad6244d220e0ae0be
+
+pkgname = backblaze-b2-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8fc413ea7a9a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname="backblaze-b2-bin"
+pkgver=3.1.0
+_pkgid="${pkgname%-bin}-${pkgver}"
+pkgrel=1
+pkgdesc="Backblaze B2 Command Line Client"
+arch=('x86_64')
+url="https://github.com/Backblaze/B2_Command_Line_Tool"
+license=('MIT')
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
+
+sha256sums_x86_64=('4b655d6d468586e07123eada3c5efdfb7ea878e19c7dea0ad6244d220e0ae0be')
+source_x86_64=("b2-linux"::"${url}/releases/download/v${pkgver}/b2-linux")
+
+prepare() {
+ chmod +x b2-linux
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/local/bin/"
+ cp "${srcdir}/b2-linux" "${pkgdir}/usr/local/bin/b2"
+}