summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Manna2016-01-15 13:41:04 -0800
committerKyle Manna2016-01-15 13:41:48 -0800
commitd130c9526de39e7026b6764bdb92a395faf3ffe8 (patch)
tree4044030fe7c4119e6415a5661913f3894312448a
downloadaur-backblaze-b2sync.tar.gz
release: 0.6.0.4
Initial release.
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD30
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b75b2de98b2e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+# Generated by mksrcinfo v8
+# Fri Jan 15 21:41:43 UTC 2016
+pkgbase = backblaze-b2sync
+ pkgdesc = Backblaze B2 Sync Tool
+ pkgver = 0.6.0.4
+ pkgrel = 1
+ url = https://www.backblaze.com/b2/docs/b2sync.html
+ arch = any
+ license = MIT
+ source = https://www.backblaze.com/b2/docs/b2sync_src.zip
+ sha512sums = 72010aefe6bc3f952f2c0230cf4d36f8ba88764e25e6cfced572ffdc462bc971df3df34cc359a39b14c5cbc417c7e8a0aa8a889c0f5064cfa165b6a1f1ccef60
+
+pkgname = backblaze-b2sync
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6f5fc7598225
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.xz
+*.tar.gz
+/src
+/pkg
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b8ff3769c46
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Kyle Manna <kyle[at]kylemanna[d0t]com>
+pkgname=backblaze-b2sync
+pkgver=0.6.0.4
+pkgrel=1
+pkgdesc="Backblaze B2 Sync Tool"
+url="https://www.backblaze.com/b2/docs/b2sync.html"
+depends=()
+optdepends=()
+# MIT or Creative Commons: https://www.backblaze.com/using_b2_code.html
+license=('MIT')
+arch=('any')
+
+# Need a better source URL at some point
+source=("https://www.backblaze.com/b2/docs/b2sync_src.zip")
+sha512sums=('72010aefe6bc3f952f2c0230cf4d36f8ba88764e25e6cfced572ffdc462bc971df3df34cc359a39b14c5cbc417c7e8a0aa8a889c0f5064cfa165b6a1f1ccef60')
+
+build() {
+ cd ${srcdir}/b2sync_src
+
+ # Backblaze fails to link with default LDFLAGS, hopefully backblaze will
+ # fix the Makefile headache.
+ LDFLAGS="" make
+}
+
+package() {
+ cd ${srcdir}/b2sync_src
+
+ install -D b2sync ${pkgdir}/usr/bin/b2sync
+}
+