summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2015-06-08 17:58:42 -0400
committergraysky2015-06-08 17:58:42 -0400
commit88a1700a21502aa64c1ef7bacd83ecde076680ab (patch)
treec14c9064747c326cc868bbb8c2c63eeb1365387e
downloadaur-88a1700a21502aa64c1ef7bacd83ecde076680ab.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
-rw-r--r--readme.install27
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..21180c38a62f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = backdrop-randomizer
+ pkgdesc = Companion for xfdesktop which randomly cycles through wallpapers without repeating them until all have been displayed once.
+ pkgver = 2.24
+ pkgrel = 1
+ url = https://github.com/graysky2/backdrop-randomizer
+ install = readme.install
+ arch = any
+ license = MIT
+ depends = xfdesktop
+ source = http://repo-ck.com/source/backdrop-randomizer/backdrop-randomizer-2.24.tar.xz
+ sha256sums = 1de09e0e11ff64d584255197273374f639035f313334b92895bcac18c65fc210
+
+pkgname = backdrop-randomizer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c3dd1d7fb31
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: graysky <graysky AT archlinux DOT us>
+
+pkgname='backdrop-randomizer'
+pkgver=2.24
+pkgrel=1
+pkgdesc='Companion for xfdesktop which randomly cycles through wallpapers without repeating them until all have been displayed once.'
+arch=('any')
+url='https://github.com/graysky2/backdrop-randomizer'
+license=('MIT')
+depends=('xfdesktop')
+source=("http://repo-ck.com/source/$pkgname/$pkgname-$pkgver.tar.xz")
+install=readme.install
+sha256sums=('1de09e0e11ff64d584255197273374f639035f313334b92895bcac18c65fc210')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/readme.install b/readme.install
new file mode 100644
index 000000000000..c058e39ac970
--- /dev/null
+++ b/readme.install
@@ -0,0 +1,27 @@
+post_install() {
+ echo '--------------------------------------------------------------------------'
+ echo ' USAGE:'
+ echo
+ echo '1. Define the path to your pics in $HOME/.config/backdrop-randomizer.conf'
+ echo ' (currently only .jpg files are supported).'
+ echo
+ echo '2. Run it once to make symlink $HOME/.config/backdrop-randomizer.jpg'
+ echo
+ echo '3. Right-click the desktop and select Desktop Settings>Background'
+ echo
+ echo '4. Setup the image to "Single image" and select the symlink from step 2.'
+ echo
+ echo '5. Call the script manually or via cron at the desired interval.'
+ echo ' (Below example shows once every 20 min):'
+ echo
+ echo ' */20 * * * * /usr/bin/backdrop-randomizer'
+ echo
+ echo ' HOW IT WORKS:'
+ echo 'Each time you or cron calls the script, it will randomly select a picture'
+ echo 'from your list to display. It will then remove the selection from the list'
+ echo 'so as not to repeat the same pic twice per cycle. When backdrop-randomizer'
+ echo 'sees you have only one pic left in your list, it regenerates the list anew'
+ echo 'and continues to cycle. The net effect is an endless rotation of your pics'
+ echo 'without a repeat.'
+ echo '--------------------------------------------------------------------------'
+}