summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-10-25 10:15:23 +0800
committerzxp198210052023-10-25 10:15:23 +0800
commit72fa94c34250d3f316deda6093638627fdbfa854 (patch)
tree243d5227c0d32fa382ecb257190a5ffab9074519
parent5652b1e51b6b8e1ce0083fd8a5a813dea74bb3be (diff)
downloadaur-72fa94c34250d3f316deda6093638627fdbfa854.tar.gz
update to 23.09.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD8
-rw-r--r--backend-ai-desktop.sh5
3 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b83d722df95c..314597a48aa0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = backend-ai-desktop-bin
pkgdesc = Backend.AI Web UI provides a convenient environment for users, while allowing various commands to be executed without CLI. It also provides some visual features that are not provided by the CLI, such as dashboards and statistics.
- pkgver = 23.09.0
+ pkgver = 23.09.1
pkgrel = 1
url = https://www.backend.ai/
arch = aarch64
@@ -11,15 +11,15 @@ pkgbase = backend-ai-desktop-bin
depends = bash
depends = electron26
depends = hicolor-icon-theme
- provides = backend-ai-desktop=23.09.0
+ provides = backend-ai-desktop=23.09.1
conflicts = backend-ai-desktop
conflicts = backend.ai
conflicts = backend.ai-desktop
source = backend-ai-desktop.sh
- sha256sums = 2a2aa770db0476e5ceb1a9f6a98622fe114734945e6c79f645a55b68d26bc6af
- source_aarch64 = backend-ai-desktop-23.09.0-aarch64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v23.09.0/backend.ai-desktop-23.09.0-linux-arm64.zip
- sha256sums_aarch64 = cfef2457a5265c81fd877e6d86905f0bdbfbfa063379a85115ae8514dcbc47f2
- source_x86_64 = backend-ai-desktop-23.09.0-x86_64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v23.09.0/backend.ai-desktop-23.09.0-linux-x64.zip
- sha256sums_x86_64 = 485ab3717a646d04421cf5ec42122d2d863a7f352f80039643a4b0289600c584
+ sha256sums = eaaecd09868c37fd24aef8f3b50467c9b270af6ad1a386ecf5a885dfe04dba89
+ source_aarch64 = backend-ai-desktop-23.09.1-aarch64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v23.09.1/backend.ai-desktop-23.09.1-linux-arm64.zip
+ sha256sums_aarch64 = ed0c62af392c9b805028110978ba226fb3ac3a13f27944cc05f668bd43c0020b
+ source_x86_64 = backend-ai-desktop-23.09.1-x86_64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v23.09.1/backend.ai-desktop-23.09.1-linux-x64.zip
+ sha256sums_x86_64 = c9343840845d501d7d57e356f6004e2b5a01e709382e0206f94394ead1f5b06b
pkgname = backend-ai-desktop-bin
diff --git a/PKGBUILD b/PKGBUILD
index 48aee9a16b77..bf89f3a60935 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=backend.ai-desktop
pkgname="${_pkgname//./-}-bin"
_appname="Backend.AI Desktop"
-pkgver=23.09.0
+pkgver=23.09.1
pkgrel=1
pkgdesc="Backend.AI Web UI provides a convenient environment for users, while allowing various commands to be executed without CLI. It also provides some visual features that are not provided by the CLI, such as dashboards and statistics."
arch=("aarch64" "x86_64")
@@ -16,9 +16,9 @@ makedepends=('asar' 'gendesk')
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.zip::${_githuburl}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-arm64.zip")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.zip::${_githuburl}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-x64.zip")
source=("${pkgname%-bin}.sh")
-sha256sums=('2a2aa770db0476e5ceb1a9f6a98622fe114734945e6c79f645a55b68d26bc6af')
-sha256sums_aarch64=('cfef2457a5265c81fd877e6d86905f0bdbfbfa063379a85115ae8514dcbc47f2')
-sha256sums_x86_64=('485ab3717a646d04421cf5ec42122d2d863a7f352f80039643a4b0289600c584')
+sha256sums=('eaaecd09868c37fd24aef8f3b50467c9b270af6ad1a386ecf5a885dfe04dba89')
+sha256sums_aarch64=('ed0c62af392c9b805028110978ba226fb3ac3a13f27944cc05f668bd43c0020b')
+sha256sums_x86_64=('c9343840845d501d7d57e356f6004e2b5a01e709382e0206f94394ead1f5b06b')
build() {
gendesk -q -f -n --pkgname="${_pkgname//./-}-bin" --categories "Development" --name "${pkgname%-bin}" --exec "${pkgname%-bin}"
asar e "${srcdir}/${_appname}-linux-"*/resources/app.asar "${srcdir}/app.asar.unpacked"
diff --git a/backend-ai-desktop.sh b/backend-ai-desktop.sh
index 831fbbe78277..d098ac28306f 100644
--- a/backend-ai-desktop.sh
+++ b/backend-ai-desktop.sh
@@ -1,6 +1,9 @@
#!/bin/bash
_ELECTRON=/usr/bin/electron26
-_ASAR="/opt/backend-ai-desktop/resources/app.asar"
+APPDIR="/opt/backend-ai-desktop"
+export PATH="${APPDIR}:${APPDIR}/usr/sbin:${PATH}"
+export LD_LIBRARY_PATH="${APPDIR}/usr/lib":"${APPDIR}/swiftshader":"${LD_LIBRARY_PATH}"
+_ASAR="${APPDIR}/resources/app.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else