summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-08-19 11:17:32 +0800
committerzxp198210052023-08-19 11:17:32 +0800
commit93313ebfea10bdd629e294e6a8cf16e149ef73e1 (patch)
tree62e65f2fe5e2479391eefd8b9cb55241d29aed0c
parent38fd5e85610fe5d5b98453e36e6589e92489b70b (diff)
downloadaur-93313ebfea10bdd629e294e6a8cf16e149ef73e1.tar.gz
update to 23.03.5
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 359db240b3d6..c1ea869953a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = backend-ai-desktop-bin
pkgdesc = Backend.AI Web UI provides a convenient environment for users, while allowing various commands to be executed without CLI. It also provides some visual features that are not provided by the CLI, such as dashboards and statistics.
- pkgver = 23.03.4
- pkgrel = 2
+ pkgver = 23.03.5
+ pkgrel = 1
url = https://www.backend.ai/
arch = aarch64
arch = x86_64
@@ -11,15 +11,15 @@ pkgbase = backend-ai-desktop-bin
depends = bash
depends = electron25
depends = hicolor-icon-theme
- provides = backend-ai-desktop=23.03.4
+ provides = backend-ai-desktop=23.03.5
conflicts = backend-ai-desktop
conflicts = backend.ai
conflicts = backend.ai-desktop
source = backend-ai-desktop.sh
sha256sums = 5f9e1775b75bb437ad0948a058bd9e387e7e74166dc1db86222a2c3fbe7cb2c2
- source_aarch64 = backend-ai-desktop-23.03.4-aarch64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v23.03.4/backend.ai-desktop-23.03.4-linux-arm64.zip
- sha256sums_aarch64 = 6820d53750d57c4629bf6d9697209b4933643b73f65b4a96a9aeebbbaab40813
- source_x86_64 = backend-ai-desktop-23.03.4-x86_64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v23.03.4/backend.ai-desktop-23.03.4-linux-x64.zip
- sha256sums_x86_64 = c9da936549d970481449aabdf53840efa4116dec4897f371f271acb54afdd823
+ source_aarch64 = backend-ai-desktop-23.03.5-aarch64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v23.03.5/backend.ai-desktop-23.03.5-linux-arm64.zip
+ sha256sums_aarch64 = 4f903b42c05136ccce7c2139f5839267a04320787bb3e4ca194ec7ed4dd96a95
+ source_x86_64 = backend-ai-desktop-23.03.5-x86_64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v23.03.5/backend.ai-desktop-23.03.5-linux-x64.zip
+ sha256sums_x86_64 = 5f05c7dcf5d98423227eab5b6290b7b2044300628381118f640864e1beae1db8
pkgname = backend-ai-desktop-bin
diff --git a/PKGBUILD b/PKGBUILD
index 82f00a516ce0..1a53991d4441 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,23 @@
pkgname=backend-ai-desktop-bin
_appname="Backend.AI Desktop"
_pkgname=backend.ai-desktop
-pkgver=23.03.4
-pkgrel=2
+pkgver=23.03.5
+pkgrel=1
pkgdesc="Backend.AI Web UI provides a convenient environment for users, while allowing various commands to be executed without CLI. It also provides some visual features that are not provided by the CLI, such as dashboards and statistics."
arch=("aarch64" "x86_64")
url="https://www.backend.ai/"
_githuburl="https://github.com/lablup/backend.ai-webui"
license=('LGPL3')
provides=("${pkgname%-bin}=${pkgver}")
-conflicts=("${pkgname%-bin}" "backend.ai" "${_pkgname}")
+conflicts=("${pkgname%-bin}" "${_pkgname%-desktop}" "${_pkgname}")
depends=('bash' 'electron25' 'hicolor-icon-theme')
makedepends=('asar' 'gendesk')
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.zip::${_githuburl}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-arm64.zip")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.zip::${_githuburl}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-x64.zip")
source=("${pkgname%-bin}.sh")
sha256sums=('5f9e1775b75bb437ad0948a058bd9e387e7e74166dc1db86222a2c3fbe7cb2c2')
-sha256sums_aarch64=('6820d53750d57c4629bf6d9697209b4933643b73f65b4a96a9aeebbbaab40813')
-sha256sums_x86_64=('c9da936549d970481449aabdf53840efa4116dec4897f371f271acb54afdd823')
+sha256sums_aarch64=('4f903b42c05136ccce7c2139f5839267a04320787bb3e4ca194ec7ed4dd96a95')
+sha256sums_x86_64=('5f05c7dcf5d98423227eab5b6290b7b2044300628381118f640864e1beae1db8')
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
install -Dm644 "${srcdir}/${_appname}-linux-x64/resources/app.asar" -t "${pkgdir}/opt/${pkgname%-bin}"