summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-22 13:16:08 +0800
committerzxp198210052024-01-22 13:16:08 +0800
commit9aba318651c81eafba1347bdf3ea1825e992f45a (patch)
tree45576fbe69f223d3024d042b77ff44e985433ea2
parentfebecf35aef4e9dc8b0f99e52eb2f314e96a056f (diff)
downloadaur-9aba318651c81eafba1347bdf3ea1825e992f45a.tar.gz
update to 23.09.8
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD12
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1882c5922a33..2e259b5e9c58 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,24 @@
pkgbase = backend-ai-desktop-bin
pkgdesc = Provides a convenient environment for users, while allowing various commands to be executed without CLI. It also provides some visual features that are not provided by the CLI, such as dashboards and statistics.
- pkgver = 23.09.7
- pkgrel = 3
+ pkgver = 23.09.8
+ pkgrel = 1
url = https://www.backend.ai/
arch = aarch64
arch = x86_64
- license = LGPL3
+ license = LicenseRef-LGPL3
makedepends = asar
makedepends = gendesk
depends = electron26
depends = hicolor-icon-theme
- provides = backend-ai-desktop=23.09.7
+ provides = backend-ai-desktop=23.09.8
conflicts = backend-ai-desktop
conflicts = backend.ai
conflicts = backend.ai-desktop
source = backend-ai-desktop.sh
sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
- source_aarch64 = backend-ai-desktop-23.09.7-aarch64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v23.09.7/backend.ai-desktop-23.09.7-linux-arm64.zip
- sha256sums_aarch64 = 48bba4f5f37a0cd1e927aba67bf709593fffc0fb5aa1104b5eca4d2c2f3554e2
- source_x86_64 = backend-ai-desktop-23.09.7-x86_64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v23.09.7/backend.ai-desktop-23.09.7-linux-x64.zip
- sha256sums_x86_64 = 6aba02d6302e6c4743529136a1e26ce5c2c734d5cf4f1da123d4a2976a990810
+ source_aarch64 = backend-ai-desktop-23.09.8-aarch64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v23.09.8/backend.ai-desktop-23.09.8-linux-arm64.zip
+ sha256sums_aarch64 = 59846be5ab2bf4378581b9c9e4784ac61a48bc83f7be1c7a6db0890db58d49a2
+ source_x86_64 = backend-ai-desktop-23.09.8-x86_64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v23.09.8/backend.ai-desktop-23.09.8-linux-x64.zip
+ sha256sums_x86_64 = 05c504a0054df575f2814878e8e97ce373bed72ae66b0bfa26cb2e7e8ac04a71
pkgname = backend-ai-desktop-bin
diff --git a/PKGBUILD b/PKGBUILD
index 55bc2098a827..ed2708199e54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
_pkgname=backend.ai-desktop
pkgname="${_pkgname//./-}-bin"
_appname="Backend.AI Desktop"
-pkgver=23.09.7
+pkgver=23.09.8
_electronversion=26
-pkgrel=3
+pkgrel=1
pkgdesc="Provides a convenient environment for users, while allowing various commands to be executed without CLI. It also provides some visual features that are not provided by the CLI, such as dashboards and statistics."
arch=(
"aarch64"
@@ -12,7 +12,7 @@ arch=(
)
url="https://www.backend.ai/"
_ghurl="https://github.com/lablup/backend.ai-webui"
-license=('LGPL3')
+license=('LicenseRef-LGPL3')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=(
"${pkgname%-bin}"
@@ -31,8 +31,8 @@ source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.zip::${_ghurl}/releases/downl
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.zip::${_ghurl}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-x64.zip")
source=("${pkgname%-bin}.sh")
sha256sums=('d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
-sha256sums_aarch64=('48bba4f5f37a0cd1e927aba67bf709593fffc0fb5aa1104b5eca4d2c2f3554e2')
-sha256sums_x86_64=('6aba02d6302e6c4743529136a1e26ce5c2c734d5cf4f1da123d4a2976a990810')
+sha256sums_aarch64=('59846be5ab2bf4378581b9c9e4784ac61a48bc83f7be1c7a6db0890db58d49a2')
+sha256sums_x86_64=('05c504a0054df575f2814878e8e97ce373bed72ae66b0bfa26cb2e7e8ac04a71')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
@@ -43,7 +43,7 @@ build() {
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/${_appname}-linux-x64/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/${_appname}-linux-"*/resources/app.asar -t "${pkgdir}/usr/lib/${pkgname%-bin}"
for _icons in 16x16 32x32 128x128 256x256 512x512;do
install -Dm644 "${srcdir}/app.asar.unpacked/app/manifest/${pkgname%-desktop-bin}.iconset/icon_${_icons}@1x.png" \
"${pkgdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png"