summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-06-16 11:57:29 +0800
committerzxp198210052024-06-16 11:57:29 +0800
commita4d385ac51fc263c243c764429191938851516d2 (patch)
tree2c1b9168ca80bea859627d777c53fd4930650f1a
parent6a949216d921e0c3f9d6639a17827ecb29643ec7 (diff)
downloadaur-a4d385ac51fc263c243c764429191938851516d2.tar.gz
update to 24.03.5
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD7
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0482dc3dbf5e..9ec7cb5d0a49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = backend-ai-desktop-bin
pkgdesc = Provides a convenient environment for users, while allowing various commands to be executed without CLI. It also provides some visual features that are not provided by the CLI, such as dashboards and statistics.
- pkgver = 24.03.4
+ pkgver = 24.03.5
pkgrel = 1
url = https://www.backend.ai/
arch = aarch64
@@ -8,17 +8,17 @@ pkgbase = backend-ai-desktop-bin
license = LGPL-3.0-or-later
makedepends = gendesk
depends = electron30
- provides = backend-ai-desktop=24.03.4
+ provides = backend-ai-desktop=24.03.5
conflicts = backend-ai-desktop
conflicts = backend.ai
conflicts = backend.ai-desktop
- source = backend-ai-desktop-24.03.4.png::https://raw.githubusercontent.com/lablup/backend.ai-webui/v24.03.4/manifest/backend-ai.iconset/icon_512x512%401x.png
+ source = backend-ai-desktop-24.03.5.png::https://raw.githubusercontent.com/lablup/backend.ai-webui/v24.03.5/manifest/backend-ai.iconset/icon_512x512%401x.png
source = backend-ai-desktop.sh
sha256sums = c54209c33c387908bfaae40a9c5f6c96bacaa52684f2546068e2b4441f4a53b3
sha256sums = 2b2e8aeed33fd71c521e49fd54fb2fa81218d16aef8bccb88d77909055ab8051
- source_aarch64 = backend-ai-desktop-24.03.4-aarch64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v24.03.4/backend.ai-desktop-24.03.4-linux-arm64.zip
- sha256sums_aarch64 = 900b32a6f0a3686e8b6e87fa0e5897d15ecfc39cef2121a27a4aee405c9a6ece
- source_x86_64 = backend-ai-desktop-24.03.4-x86_64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v24.03.4/backend.ai-desktop-24.03.4-linux-x64.zip
- sha256sums_x86_64 = 42b662d56dd422c8dbdc223cb5610d799429e4452577411722180c05fadf9b9d
+ source_aarch64 = backend-ai-desktop-24.03.5-aarch64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v24.03.5/backend.ai-desktop-24.03.5-linux-arm64.zip
+ sha256sums_aarch64 = e94bc2a5d56fb43e8d4578d7165801d0111a5ac9fd2507c25f3ab196ae45dc8c
+ source_x86_64 = backend-ai-desktop-24.03.5-x86_64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v24.03.5/backend.ai-desktop-24.03.5-linux-x64.zip
+ sha256sums_x86_64 = 454844fbce58b9e7f004625ff73450520237a2f934197bb695ca89726307063f
pkgname = backend-ai-desktop-bin
diff --git a/PKGBUILD b/PKGBUILD
index 976e0f3e8794..354c1b1d251a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=backend.ai-desktop
pkgname="${_pkgname//./-}-bin"
_appname="Backend.AI Desktop"
-pkgver=24.03.4
+pkgver=24.03.5
_electronversion=30
pkgrel=1
pkgdesc="Provides a convenient environment for users, while allowing various commands to be executed without CLI. It also provides some visual features that are not provided by the CLI, such as dashboards and statistics."
@@ -33,8 +33,8 @@ source=(
)
sha256sums=('c54209c33c387908bfaae40a9c5f6c96bacaa52684f2546068e2b4441f4a53b3'
'2b2e8aeed33fd71c521e49fd54fb2fa81218d16aef8bccb88d77909055ab8051')
-sha256sums_aarch64=('900b32a6f0a3686e8b6e87fa0e5897d15ecfc39cef2121a27a4aee405c9a6ece')
-sha256sums_x86_64=('42b662d56dd422c8dbdc223cb5610d799429e4452577411722180c05fadf9b9d')
+sha256sums_aarch64=('e94bc2a5d56fb43e8d4578d7165801d0111a5ac9fd2507c25f3ab196ae45dc8c')
+sha256sums_x86_64=('454844fbce58b9e7f004625ff73450520237a2f934197bb695ca89726307063f')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
@@ -43,7 +43,6 @@ build() {
-e "s|@options@|env ELECTRON_OZONE_PLATFORM_HINT=auto|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
gendesk -q -f -n --pkgname="${pkgname%-bin}" --pkgdesc="${pkgdesc}" --categories="Development" --name="${pkgname%-bin}" --exec="${pkgname%-bin} %U"
- asar e "${srcdir}/${_appname}-linux-"*/resources/app.asar "${srcdir}/app.asar.unpacked"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"