summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-13 17:25:33 +0800
committerzxp198210052024-03-13 17:25:33 +0800
commitac9525aa746a81092eecc9ecaf951d6bd8764913 (patch)
treeadf7a71b923c7ea318ef90198e7d362d2e247628
parent9532f1113ecf3abc4353b367b9733e03a92afbe0 (diff)
downloadaur-ac9525aa746a81092eecc9ecaf951d6bd8764913.tar.gz
fix errors
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
-rw-r--r--backend-ai-desktop.sh13
3 files changed, 21 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51171da39ea7..87294262a33d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
pkgbase = backend-ai-desktop-bin
pkgdesc = Provides a convenient environment for users, while allowing various commands to be executed without CLI. It also provides some visual features that are not provided by the CLI, such as dashboards and statistics.
pkgver = 23.09.9
- pkgrel = 1
+ pkgrel = 2
url = https://www.backend.ai/
arch = aarch64
arch = x86_64
license = LGPL-3.0-only
- makedepends = asar
makedepends = gendesk
depends = electron26
- depends = hicolor-icon-theme
provides = backend-ai-desktop=23.09.9
conflicts = backend-ai-desktop
conflicts = backend.ai
conflicts = backend.ai-desktop
+ source = backend-ai-desktop-23.09.9.png::https://raw.githubusercontent.com/lablup/backend.ai-webui/v23.09.9/manifest/backend-ai.iconset/icon_512x512%401x.png
source = backend-ai-desktop.sh
- sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
+ sha256sums = c54209c33c387908bfaae40a9c5f6c96bacaa52684f2546068e2b4441f4a53b3
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
source_aarch64 = backend-ai-desktop-23.09.9-aarch64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v23.09.9/backend.ai-desktop-23.09.9-linux-arm64.zip
sha256sums_aarch64 = 1f1a905b2501d11a554c7a45000f9b0de6adf5925a4e648bebcf70452fe7ad9f
source_x86_64 = backend-ai-desktop-23.09.9-x86_64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v23.09.9/backend.ai-desktop-23.09.9-linux-x64.zip
diff --git a/PKGBUILD b/PKGBUILD
index 5c0a44702867..3637374bb58a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname="${_pkgname//./-}-bin"
_appname="Backend.AI Desktop"
pkgver=23.09.9
_electronversion=26
-pkgrel=1
+pkgrel=2
pkgdesc="Provides a convenient environment for users, while allowing various commands to be executed without CLI. It also provides some visual features that are not provided by the CLI, such as dashboards and statistics."
arch=(
"aarch64"
@@ -21,22 +21,25 @@ conflicts=(
)
depends=(
"electron${_electronversion}"
- 'hicolor-icon-theme'
)
makedepends=(
- 'asar'
'gendesk'
)
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.zip::${_ghurl}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-arm64.zip")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.zip::${_ghurl}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-x64.zip")
-source=("${pkgname%-bin}.sh")
-sha256sums=('d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
+source=(
+ "${pkgname%-bin}-${pkgver}.png::https://raw.githubusercontent.com/lablup/backend.ai-webui/v${pkgver}/manifest/backend-ai.iconset/icon_512x512%401x.png"
+ "${pkgname%-bin}.sh"
+)
+sha256sums=('c54209c33c387908bfaae40a9c5f6c96bacaa52684f2546068e2b4441f4a53b3'
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
sha256sums_aarch64=('1f1a905b2501d11a554c7a45000f9b0de6adf5925a4e648bebcf70452fe7ad9f')
sha256sums_x86_64=('8c6474d76516aac0bd54635b2331ecc3f2983f4f4a3f5512f3fbff8788a2bb2e')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app.asar|g" \
+ -e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
gendesk -q -f -n --pkgname="${_pkgname//./-}-bin" --categories="Development" --name="${pkgname%-bin}" --exec="${pkgname%-bin} %U"
asar e "${srcdir}/${_appname}-linux-"*/resources/app.asar "${srcdir}/app.asar.unpacked"
@@ -44,9 +47,6 @@ build() {
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
install -Dm644 "${srcdir}/${_appname}-linux-"*/resources/app.asar -t "${pkgdir}/usr/lib/${pkgname%-bin}"
- for _icons in 16x16 32x32 128x128 256x256 512x512;do
- install -Dm644 "${srcdir}/app.asar.unpacked/app/manifest/${pkgname%-desktop-bin}.iconset/icon_${_icons}@1x.png" \
- "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png"
- done
+ install -Dm644 "${srcdir}/${pkgname%-bin}-${pkgver}.png" "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png"
install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
} \ No newline at end of file
diff --git a/backend-ai-desktop.sh b/backend-ai-desktop.sh
index aacd8f895847..7ddcaab8d734 100644
--- a/backend-ai-desktop.sh
+++ b/backend-ai-desktop.sh
@@ -1,15 +1,16 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@"
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi
-exit \ No newline at end of file
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
+fi \ No newline at end of file