summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-10-27 11:18:31 +0800
committerzxp198210052023-10-27 11:18:31 +0800
commite62425fad465cc0303ef8c682546c7c10d2a8418 (patch)
treeb07630b0db3c1fdce9665a16b11fc3a24fca2332
parent72fa94c34250d3f316deda6093638627fdbfa854 (diff)
downloadaur-e62425fad465cc0303ef8c682546c7c10d2a8418.tar.gz
update to 23.09.2
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD10
-rw-r--r--backend-ai-desktop.sh5
3 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 314597a48aa0..7154941ce95e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = backend-ai-desktop-bin
pkgdesc = Backend.AI Web UI provides a convenient environment for users, while allowing various commands to be executed without CLI. It also provides some visual features that are not provided by the CLI, such as dashboards and statistics.
- pkgver = 23.09.1
+ pkgver = 23.09.2
pkgrel = 1
url = https://www.backend.ai/
arch = aarch64
@@ -11,15 +11,15 @@ pkgbase = backend-ai-desktop-bin
depends = bash
depends = electron26
depends = hicolor-icon-theme
- provides = backend-ai-desktop=23.09.1
+ provides = backend-ai-desktop=23.09.2
conflicts = backend-ai-desktop
conflicts = backend.ai
conflicts = backend.ai-desktop
source = backend-ai-desktop.sh
- sha256sums = eaaecd09868c37fd24aef8f3b50467c9b270af6ad1a386ecf5a885dfe04dba89
- source_aarch64 = backend-ai-desktop-23.09.1-aarch64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v23.09.1/backend.ai-desktop-23.09.1-linux-arm64.zip
- sha256sums_aarch64 = ed0c62af392c9b805028110978ba226fb3ac3a13f27944cc05f668bd43c0020b
- source_x86_64 = backend-ai-desktop-23.09.1-x86_64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v23.09.1/backend.ai-desktop-23.09.1-linux-x64.zip
- sha256sums_x86_64 = c9343840845d501d7d57e356f6004e2b5a01e709382e0206f94394ead1f5b06b
+ sha256sums = bcda93b2c524c907a016454bbcbffdc35bee6b5509145691f634e601fc00abae
+ source_aarch64 = backend-ai-desktop-23.09.2-aarch64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v23.09.2/backend.ai-desktop-23.09.2-linux-arm64.zip
+ sha256sums_aarch64 = 5b31c69aebd24a7ed1fa13f99d64d17041cbd69f831a62e328d84ec550e081e0
+ source_x86_64 = backend-ai-desktop-23.09.2-x86_64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v23.09.2/backend.ai-desktop-23.09.2-linux-x64.zip
+ sha256sums_x86_64 = f371d789f6ea217819a51e97a0a855caccf236f4a6ed6b60d64fdd32f1dd7881
pkgname = backend-ai-desktop-bin
diff --git a/PKGBUILD b/PKGBUILD
index bf89f3a60935..230f57c80f2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=backend.ai-desktop
pkgname="${_pkgname//./-}-bin"
_appname="Backend.AI Desktop"
-pkgver=23.09.1
+pkgver=23.09.2
pkgrel=1
pkgdesc="Backend.AI Web UI provides a convenient environment for users, while allowing various commands to be executed without CLI. It also provides some visual features that are not provided by the CLI, such as dashboards and statistics."
arch=("aarch64" "x86_64")
@@ -16,16 +16,16 @@ makedepends=('asar' 'gendesk')
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.zip::${_githuburl}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-arm64.zip")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.zip::${_githuburl}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-x64.zip")
source=("${pkgname%-bin}.sh")
-sha256sums=('eaaecd09868c37fd24aef8f3b50467c9b270af6ad1a386ecf5a885dfe04dba89')
-sha256sums_aarch64=('ed0c62af392c9b805028110978ba226fb3ac3a13f27944cc05f668bd43c0020b')
-sha256sums_x86_64=('c9343840845d501d7d57e356f6004e2b5a01e709382e0206f94394ead1f5b06b')
+sha256sums=('bcda93b2c524c907a016454bbcbffdc35bee6b5509145691f634e601fc00abae')
+sha256sums_aarch64=('5b31c69aebd24a7ed1fa13f99d64d17041cbd69f831a62e328d84ec550e081e0')
+sha256sums_x86_64=('f371d789f6ea217819a51e97a0a855caccf236f4a6ed6b60d64fdd32f1dd7881')
build() {
gendesk -q -f -n --pkgname="${_pkgname//./-}-bin" --categories "Development" --name "${pkgname%-bin}" --exec "${pkgname%-bin}"
asar e "${srcdir}/${_appname}-linux-"*/resources/app.asar "${srcdir}/app.asar.unpacked"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/${_appname}-linux-x64/resources/app.asar" -t "${pkgdir}/opt/${pkgname%-bin}/resources"
+ install -Dm644 "${srcdir}/${_appname}-linux-x64/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
for _icons in 16x16 32x32 128x128 256x256 512x512;do
install -Dm644 "${srcdir}/app.asar.unpacked/app/manifest/${pkgname%-desktop-bin}.iconset/icon_${_icons}@1x.png" \
"${pkgdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png"
diff --git a/backend-ai-desktop.sh b/backend-ai-desktop.sh
index d098ac28306f..90049606a0b7 100644
--- a/backend-ai-desktop.sh
+++ b/backend-ai-desktop.sh
@@ -1,9 +1,8 @@
#!/bin/bash
_ELECTRON=/usr/bin/electron26
-APPDIR="/opt/backend-ai-desktop"
+APPDIR="/usr/lib/backend-ai-desktop"
export PATH="${APPDIR}:${APPDIR}/usr/sbin:${PATH}"
-export LD_LIBRARY_PATH="${APPDIR}/usr/lib":"${APPDIR}/swiftshader":"${LD_LIBRARY_PATH}"
-_ASAR="${APPDIR}/resources/app.asar"
+_ASAR="${APPDIR}/app.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else