summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-19 15:17:37 +0800
committerzxp198210052024-01-19 15:17:37 +0800
commitfebecf35aef4e9dc8b0f99e52eb2f314e96a056f (patch)
tree0d4012e2c681c694a9b20c903c71b05a0c0d85f0
parenta2485c03b8bfce36eb959b3fa8bc79d71a461009 (diff)
downloadaur-febecf35aef4e9dc8b0f99e52eb2f314e96a056f.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--backend-ai-desktop.sh13
3 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67ea87e9b63e..1882c5922a33 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = backend-ai-desktop-bin
pkgdesc = Provides a convenient environment for users, while allowing various commands to be executed without CLI. It also provides some visual features that are not provided by the CLI, such as dashboards and statistics.
pkgver = 23.09.7
- pkgrel = 2
+ pkgrel = 3
url = https://www.backend.ai/
arch = aarch64
arch = x86_64
@@ -15,7 +15,7 @@ pkgbase = backend-ai-desktop-bin
conflicts = backend.ai
conflicts = backend.ai-desktop
source = backend-ai-desktop.sh
- sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
+ sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
source_aarch64 = backend-ai-desktop-23.09.7-aarch64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v23.09.7/backend.ai-desktop-23.09.7-linux-arm64.zip
sha256sums_aarch64 = 48bba4f5f37a0cd1e927aba67bf709593fffc0fb5aa1104b5eca4d2c2f3554e2
source_x86_64 = backend-ai-desktop-23.09.7-x86_64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v23.09.7/backend.ai-desktop-23.09.7-linux-x64.zip
diff --git a/PKGBUILD b/PKGBUILD
index f2788206b5ae..55bc2098a827 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname="${_pkgname//./-}-bin"
_appname="Backend.AI Desktop"
pkgver=23.09.7
_electronversion=26
-pkgrel=2
+pkgrel=3
pkgdesc="Provides a convenient environment for users, while allowing various commands to be executed without CLI. It also provides some visual features that are not provided by the CLI, such as dashboards and statistics."
arch=(
"aarch64"
@@ -30,7 +30,7 @@ makedepends=(
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.zip::${_ghurl}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-arm64.zip")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.zip::${_ghurl}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-x64.zip")
source=("${pkgname%-bin}.sh")
-sha256sums=('8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
+sha256sums=('d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
sha256sums_aarch64=('48bba4f5f37a0cd1e927aba67bf709593fffc0fb5aa1104b5eca4d2c2f3554e2')
sha256sums_x86_64=('6aba02d6302e6c4743529136a1e26ce5c2c734d5cf4f1da123d4a2976a990810')
build() {
@@ -38,7 +38,7 @@ build() {
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@appasar@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- gendesk -q -f -n --pkgname="${_pkgname//./-}-bin" --categories "Development" --name "${pkgname%-bin}" --exec "${pkgname%-bin}"
+ gendesk -q -f -n --pkgname="${_pkgname//./-}-bin" --categories "Development" --name "${pkgname%-bin}" --exec "${pkgname%-bin} %U"
asar e "${srcdir}/${_appname}-linux-"*/resources/app.asar "${srcdir}/app.asar.unpacked"
}
package() {
diff --git a/backend-ai-desktop.sh b/backend-ai-desktop.sh
index 2ec4412e5c4f..aacd8f895847 100644
--- a/backend-ai-desktop.sh
+++ b/backend-ai-desktop.sh
@@ -1,14 +1,15 @@
-#!/bin/bash
+#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
+_ASAR="${_APPDIR}/@appasar@"
export PATH="${_APPDIR}:${PATH}"
-export ELECTRON_IS_DEV=0
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
-_ASAR="${_APPDIR}/@appasar@"
+export ELECTRON_IS_DEV=0
+export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" "$@"
else
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi \ No newline at end of file
+fi
+exit \ No newline at end of file