summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2016-01-10 14:59:19 -0500
committergraysky2016-01-10 14:59:19 -0500
commit0bc3a1dd03d47b8409bf7477296624fff511dd31 (patch)
tree74117e9ca7a081867bd54ad7a90ff8dcdaa69e74
parentee676a96f1dc6904d8777533793335b2f8e8d7fb (diff)
downloadaur-0bc3a1dd03d47b8409bf7477296624fff511dd31.tar.gz
Update to 1.1.10-1
-rw-r--r--.SRCINFO14
-rw-r--r--Fix_bug_473-AttributeError.patch32
-rw-r--r--PKGBUILD23
3 files changed, 19 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a81b57c58f9..806219651757 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
# Generated by mksrcinfo v8
-# Wed Dec 16 19:51:16 UTC 2015
+# Sun Jan 10 19:59:19 UTC 2016
pkgbase = backintime
- pkgver = 1.1.8
- pkgrel = 4
+ pkgver = 1.1.10
+ pkgrel = 1
url = https://github.com/bit-team/backintime
arch = any
license = GPL
makedepends = python
- source = https://github.com/bit-team/backintime/archive/v1.1.8.tar.gz
- source = Fix_bug_473-AttributeError.patch
- sha256sums = d5475eddcbe9612eb8814cb811bee394ad140a560d28c4d20258f3a6078648ff
- sha256sums = 281b75fa6726e621b8ecabe8310b7e9e126848eb2215082df38fdf2cbdc52786
+ source = https://github.com/bit-team/backintime/archive/v1.1.10.tar.gz
+ sha256sums = e3aa1cdae80b076d404977589741e612053a86aaa2fc36927e231ec184bd523b
pkgname = backintime
pkgdesc = Simple backup system inspired from the Flyback Project and TimeVault. QT4 GUI version.
- depends = backintime-cli=1.1.8
+ depends = backintime-cli=1.1.10
depends = xorg-xdpyinfo
depends = python-pyqt4
depends = libnotify
diff --git a/Fix_bug_473-AttributeError.patch b/Fix_bug_473-AttributeError.patch
deleted file mode 100644
index 2af4c9561cc5..000000000000
--- a/Fix_bug_473-AttributeError.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-=== modified file 'common/config.py'
---- common/config.py 2015-09-28 20:19:24 +0000
-+++ common/config.py 2015-12-13 19:32:09 +0000
-@@ -28,8 +28,8 @@
- import getpass
- pwd = None
-
-+import tools
- import configfile
--import tools
- import logger
- import mount
- import sshtools
-
-=== modified file 'common/tools.py'
---- common/tools.py 2015-08-23 22:21:04 +0000
-+++ common/tools.py 2015-12-13 19:31:42 +0000
-@@ -1169,5 +1169,13 @@
- return
- self.iface.clean()
-
-+def __log_keyring_warning():
-+ from time import sleep
-+ sleep(0.1)
-+ logger.warning('import keyring failed')
-+
- if keyring is None and keyring_warn:
-- logger.warning('import keyring failed')
-+ #delay warning to give logger some time to import
-+ import _thread
-+ _thread.start_new_thread(__log_keyring_warning, ())
-+ # logger.warning('import keyring failed')
diff --git a/PKGBUILD b/PKGBUILD
index 09696b2911e9..bd22a92b3bda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,19 @@
pkgname=('backintime' 'backintime-cli')
_pkgname="backintime"
-pkgver=1.1.8
-pkgrel=4
+pkgver=1.1.10
+pkgrel=1
arch=('any')
url="https://github.com/bit-team/backintime"
license=('GPL')
makedepends=('python')
-source=("https://github.com/bit-team/$_pkgname/archive/v$pkgver.tar.gz"
-"Fix_bug_473-AttributeError.patch")
-sha256sums=('d5475eddcbe9612eb8814cb811bee394ad140a560d28c4d20258f3a6078648ff'
- '281b75fa6726e621b8ecabe8310b7e9e126848eb2215082df38fdf2cbdc52786')
+source=("https://github.com/bit-team/$_pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('e3aa1cdae80b076d404977589741e612053a86aaa2fc36927e231ec184bd523b')
-prepare() {
- cd "$_pkgname-$pkgver/common"
- patch -i "$srcdir/Fix_bug_473-AttributeError.patch"
-}
+#prepare() {
+# cd "$_pkgname-$pkgver/common"
+# patch -i "$srcdir/Fix_bug_473-AttributeError.patch"
+#}
build() {
cd "$_pkgname-$pkgver/common"
@@ -29,6 +27,11 @@ build() {
make
}
+test() {
+ cd "$_pkgname-$pkgver/common"
+ make test
+}
+
package_backintime-cli() {
pkgdesc="Simple backup system inspired from the Flyback Project and TimeVault. CLI version."
depends=('rsync' 'cron' 'openssh' 'python-keyring' 'python-dbus' 'polkit')