summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2019-04-27 10:12:02 -0400
committergraysky2019-04-27 10:12:02 -0400
commit54850d0293ee18d0db1a0b2c4ec08d2297aa8acc (patch)
tree212acd8606b829c1cabbcfbe3752e70321833c0b
parent2eb754ea07a016a1f0ac0a4110cd19d475826cee (diff)
downloadaur-54850d0293ee18d0db1a0b2c4ec08d2297aa8acc.tar.gz
Update to 1.2.0-1
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD68
2 files changed, 45 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb1d6af0edad..042ed614318c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,38 +1,36 @@
# Generated by mksrcinfo v8
-# Sun Jan 6 15:58:36 UTC 2019
+# Sat Apr 27 14:12:02 UTC 2019
pkgbase = backintime
- pkgver = 1.1.24
- pkgrel = 2
+ pkgver = 1.2.0
+ pkgrel = 1
url = https://github.com/bit-team/backintime
arch = any
license = GPL
makedepends = python
- source = backintime-1.1.24.tar.gz::https://github.com/bit-team/backintime/archive/v1.1.24.tar.gz
- sha256sums = 74f391217c3fc33cea75abbd758914a003c1ee3bf815f31a75e7dc4c7bf11960
+ source = backintime-1.2.0.tar.gz::https://github.com/bit-team/backintime/archive/v1.2.0.tar.gz
+ sha256sums = 79eb77060df2471b0a3baacacab237cc4ee0d712d27e5b98c5398550e89d2115
pkgname = backintime
- pkgdesc = Simple backup system inspired from the Flyback Project and TimeVault. QT4 GUI version.
- depends = backintime-cli=1.1.24
- depends = xorg-xdpyinfo
- depends = python-pyqt4
+ pkgdesc = Simple backup system inspired from the Flyback Project and TimeVault. QT5 GUI version.
+ depends = backintime-cli=1.2.0
depends = libnotify
- depends = ttf-font
- depends = icu
depends = polkit
+ depends = python-dbus
+ depends = python-pyqt5
+ depends = xorg-xdpyinfo
optdepends = kompare: diff/patch frontend
optdepends = meld: diff/patch frontend
optdepends = python-keyring: store and access passwords safely
pkgname = backintime-cli
pkgdesc = Simple backup system inspired from the Flyback Project and TimeVault. CLI version.
- depends = rsync
depends = cron
+ depends = fuse2
depends = openssh
- depends = python-keyring
depends = python-dbus
- depends = polkit
- depends = python-sip-pyqt4
- optdepends = backintime: QT4 GUI version
+ depends = python-keyring
+ depends = rsync
+ optdepends = backintime: QT5 GUI version
optdepends = encfs: encrypted filesystem in user-space
optdepends = pm-utils: for laptops allows an option to not snapshot on battery
optdepends = sshfs: FUSE client based on the ssh file transfer protocol
diff --git a/PKGBUILD b/PKGBUILD
index b77cd57484b8..a4fd705da836 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,59 +3,53 @@
pkgname=('backintime' 'backintime-cli')
_pkgname="backintime"
-pkgver=1.1.24
-pkgrel=2
+pkgver=1.2.0
+pkgrel=1
arch=('any')
url="https://github.com/bit-team/backintime"
license=('GPL')
makedepends=('python')
#source=("https://github.com/bit-team/$_pkgname/archive/v$pkgver.tar.gz")
source=("$_pkgname-$pkgver.tar.gz::https://github.com/bit-team/$_pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('74f391217c3fc33cea75abbd758914a003c1ee3bf815f31a75e7dc4c7bf11960')
-
-prepare() {
- cd "$_pkgname-$pkgver"
-
- # patches here
-}
+sha256sums=('79eb77060df2471b0a3baacacab237cc4ee0d712d27e5b98c5398550e89d2115')
build() {
- cd "$_pkgname-$pkgver/common"
- ./configure --python --no-fuse-group
- make
+ cd "$_pkgname-$pkgver/common"
+ ./configure --python --no-fuse-group
+ make
- cd "$srcdir/$_pkgname-$pkgver/qt4"
- ./configure --python
- make
+ cd "$srcdir/$_pkgname-$pkgver/qt"
+ ./configure --python
+ make
}
test() {
- cd "$_pkgname-$pkgver/common"
- make test
+ cd "$_pkgname-$pkgver/common"
+ make test
}
package_backintime-cli() {
- pkgdesc="Simple backup system inspired from the Flyback Project and TimeVault. CLI version."
- depends=('rsync' 'cron' 'openssh' 'python-keyring' 'python-dbus' 'polkit' 'python-sip-pyqt4')
- optdepends=('backintime: QT4 GUI version'
- 'encfs: encrypted filesystem in user-space'
- 'pm-utils: for laptops allows an option to not snapshot on battery'
- 'sshfs: FUSE client based on the ssh file transfer protocol')
-
- cd "$_pkgname-$pkgver/common"
- make DESTDIR="$pkgdir" install
+ pkgdesc="Simple backup system inspired from the Flyback Project and TimeVault. CLI version."
+ depends=('cron' 'fuse2' 'openssh' 'python-dbus' 'python-keyring' 'rsync')
+ optdepends=('backintime: QT5 GUI version'
+ 'encfs: encrypted filesystem in user-space'
+ 'pm-utils: for laptops allows an option to not snapshot on battery'
+ 'sshfs: FUSE client based on the ssh file transfer protocol')
+
+ cd "$_pkgname-$pkgver/common"
+ make DESTDIR="$pkgdir" install
}
package_backintime() {
- pkgdesc="Simple backup system inspired from the Flyback Project and TimeVault. QT4 GUI version."
- depends=("backintime-cli=$pkgver" 'xorg-xdpyinfo' 'python-pyqt4' 'libnotify'
- 'ttf-font' 'icu' 'polkit')
-
- # note users can optionally install EITHER kompare OR meld but not both!
- optdepends=('kompare: diff/patch frontend'
- 'meld: diff/patch frontend'
- 'python-keyring: store and access passwords safely')
-
- cd "$_pkgname-$pkgver/qt4"
- make DESTDIR="$pkgdir" install
+ pkgdesc="Simple backup system inspired from the Flyback Project and TimeVault. QT5 GUI version."
+ depends=("backintime-cli=$pkgver" 'libnotify' 'polkit' 'python-dbus' 'python-pyqt5' 'xorg-xdpyinfo')
+ # note users can optionally install EITHER kompare OR meld but not both!
+ optdepends=('kompare: diff/patch frontend'
+ 'meld: diff/patch frontend'
+ 'python-keyring: store and access passwords safely')
+
+ cd "$_pkgname-$pkgver/qt"
+ make DESTDIR="$pkgdir" install
}
+
+# vim:set ts=8 sts=2 sw=2 et: