summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2016-06-24 02:24:57 -0400
committergraysky2016-06-24 02:24:57 -0400
commit5c1903d7e5b8f1f5da8dc48d868359460a5eac4e (patch)
tree4f9dafce3afefaeb300f9dade7db591a49b56d9a
parentdebcf52b4731128614cfc6effe7ceb4a59d51ace (diff)
downloadaur-5c1903d7e5b8f1f5da8dc48d868359460a5eac4e.tar.gz
Update to 1.1.12-4
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--keyring1.1.12.patch24
3 files changed, 36 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f739eb910dd5..ae0969330c53 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
# Generated by mksrcinfo v8
-# Sun Mar 27 01:09:32 UTC 2016
+# Fri Jun 24 06:24:57 UTC 2016
pkgbase = backintime
pkgver = 1.1.12
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/bit-team/backintime
arch = any
license = GPL
makedepends = python
source = https://github.com/bit-team/backintime/archive/v1.1.12.tar.gz
source = pkexec1.1.12.patch
+ source = keyring1.1.12.patch
sha256sums = 76036de6abdf5a2b2fbf66311c369dce7e3755fa778e5f01aa49bc2be68eb9f1
sha256sums = b5be2317976db5d946047b5daa7ef75b029498225a9bb2763a18c93b07686e5e
+ sha256sums = 9ae26aa553b7917771b97c3f0b16459ea0f79130a7505b09f1feba93d96c1025
pkgname = backintime
pkgdesc = Simple backup system inspired from the Flyback Project and TimeVault. QT4 GUI version.
diff --git a/PKGBUILD b/PKGBUILD
index df7b5094bbf4..5a05f6ebc2da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,22 @@
pkgname=('backintime' 'backintime-cli')
_pkgname="backintime"
pkgver=1.1.12
-pkgrel=3
+pkgrel=4
arch=('any')
url="https://github.com/bit-team/backintime"
license=('GPL')
makedepends=('python')
source=("https://github.com/bit-team/$_pkgname/archive/v$pkgver.tar.gz"
-'pkexec1.1.12.patch')
+'pkexec1.1.12.patch'
+'keyring1.1.12.patch')
sha256sums=('76036de6abdf5a2b2fbf66311c369dce7e3755fa778e5f01aa49bc2be68eb9f1'
- 'b5be2317976db5d946047b5daa7ef75b029498225a9bb2763a18c93b07686e5e')
+ 'b5be2317976db5d946047b5daa7ef75b029498225a9bb2763a18c93b07686e5e'
+ '9ae26aa553b7917771b97c3f0b16459ea0f79130a7505b09f1feba93d96c1025')
prepare() {
- cd "$_pkgname-$pkgver/qt4"
- patch -i "$srcdir/pkexec1.1.12.patch"
+ cd "$_pkgname-$pkgver"
+ patch -Np1 -i "$srcdir/keyring1.1.12.patch"
+ patch -Np1 -i "$srcdir/pkexec1.1.12.patch"
}
build() {
diff --git a/keyring1.1.12.patch b/keyring1.1.12.patch
new file mode 100644
index 000000000000..4d4ce4581c7b
--- /dev/null
+++ b/keyring1.1.12.patch
@@ -0,0 +1,24 @@
+diff --git a/common/tools.py b/common/tools.py
+index e1da01b..c13fb06 100644
+--- a/common/tools.py
++++ b/common/tools.py
+@@ -597,6 +597,8 @@ def keyring_supported():
+ except: pass
+ try: backends.append(keyring.backends.kwallet.Keyring)
+ except: pass
++ try: backends.append(keyring.backends.kwallet.DBusKeyring)
++ except: pass
+ try: backends.append(keyring.backend.SecretServiceKeyring)
+ except: pass
+ try: backends.append(keyring.backend.GnomeKeyring)
+@@ -607,9 +609,9 @@ def keyring_supported():
+ displayName = keyring.get_keyring().__module__
+ except:
+ displayName = str(keyring.get_keyring())
+- if backends:
++ if backends and isinstance(keyring.get_keyring(), tuple(backends)):
+ logger.debug("Found appropriate keyring '{}'".format(displayName))
+- return isinstance(keyring.get_keyring(), tuple(backends))
++ return True
+ logger.debug("No appropriate keyring found. '{}' can't be used with BackInTime".format(displayName))
+ return False