summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2022-03-14 15:07:02 -0400
committergraysky2022-03-14 15:07:02 -0400
commitb57c309d06fdd1727d70d14b7d1231d0dc773aac (patch)
treeb3e77e336511342f6de09d907c71ed1c91053aa3
parentb1b4129cd34d219000e61221fce49d918973c722 (diff)
downloadaur-b57c309d06fdd1727d70d14b7d1231d0dc773aac.tar.gz
Update to 1.3.2-2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD26
2 files changed, 17 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 79bef88e17d0..dc2db736e9ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = backintime
pkgver = 1.3.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/bit-team/backintime
arch = any
license = GPL
@@ -10,7 +10,9 @@ pkgbase = backintime
checkdepends = systemd
makedepends = python
source = backintime-1.3.2.tar.gz::https://github.com/bit-team/backintime/archive/v1.3.2.tar.gz
+ source = 001-fix-test-test_tools-add-sleep-for-flaky-systems.patch::https://patch-diff.githubusercontent.com/raw/bit-team/backintime/pull/1214.patch
b2sums = 64d312ca8f140bf42ed8d41cb915adc8e181e535e13f9a2b2f1cee9c8ab18254df15604b869f98e5978cb204d558eaf602ea3d158a52527843ba2c045d702545
+ b2sums = f840b40cebb5a360db319fddb404217cff94e62df36e155ebd41ff44cf357a29697c461e83b878d044230f902b91beaaccf604d12e68d93f58c0b5360237cb7e
pkgname = backintime
pkgdesc = Simple backup system inspired from the Flyback Project and TimeVault. QT5 GUI version.
diff --git a/PKGBUILD b/PKGBUILD
index c289a94c3801..d41d68197b79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,21 @@
pkgname=(backintime backintime-cli)
_pkgname="backintime"
pkgver=1.3.2
-pkgrel=1
+pkgrel=2
arch=(any)
url="https://github.com/bit-team/backintime"
license=(GPL)
makedepends=(python)
checkdepends=(openssh python-dbus rsync systemd)
-source=("$_pkgname-$pkgver.tar.gz::https://github.com/bit-team/$_pkgname/archive/v$pkgver.tar.gz")
-b2sums=('64d312ca8f140bf42ed8d41cb915adc8e181e535e13f9a2b2f1cee9c8ab18254df15604b869f98e5978cb204d558eaf602ea3d158a52527843ba2c045d702545')
-
-#prepare() {
-# cd "$_pkgname-$pkgver"
-# patch -p1 -i ../
-#}
+source=("$_pkgname-$pkgver.tar.gz::https://github.com/bit-team/$_pkgname/archive/v$pkgver.tar.gz"
+ 001-fix-test-test_tools-add-sleep-for-flaky-systems.patch::https://patch-diff.githubusercontent.com/raw/bit-team/backintime/pull/1214.patch)
+b2sums=('64d312ca8f140bf42ed8d41cb915adc8e181e535e13f9a2b2f1cee9c8ab18254df15604b869f98e5978cb204d558eaf602ea3d158a52527843ba2c045d702545'
+ 'f840b40cebb5a360db319fddb404217cff94e62df36e155ebd41ff44cf357a29697c461e83b878d044230f902b91beaaccf604d12e68d93f58c0b5360237cb7e')
+
+prepare() {
+ cd "$_pkgname-$pkgver"
+ patch -p1 -i ../001-fix-test-test_tools-add-sleep-for-flaky-systems.patch
+}
build() {
cd "$_pkgname-$pkgver/common"
@@ -28,10 +30,10 @@ build() {
make
}
-#check() {
-# cd "$_pkgname-$pkgver/common"
-# make test
-#}
+check() {
+ cd "$_pkgname-$pkgver/common"
+ make test
+}
package_backintime-cli() {
pkgdesc="Simple backup system inspired from the Flyback Project and TimeVault. CLI version."