summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2015-12-13 14:59:38 -0500
committergraysky2015-12-13 14:59:38 -0500
commitdd8f939e8dbff30df83a1ab7dce2035eb79f12ba (patch)
tree8b75c3c6ced7d3d9d901efa653393e3729ee0973
parent2351a9e985ab7e099850579cc18aa8885610c541 (diff)
downloadaur-dd8f939e8dbff30df83a1ab7dce2035eb79f12ba.tar.gz
Update to 1.1.8-3
-rw-r--r--.SRCINFO6
-rw-r--r--Fix_bug_473-AttributeError.patch29
-rw-r--r--PKGBUILD4
3 files changed, 21 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f532814ccd3..726d6654d94d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Dec 13 18:23:37 UTC 2015
+# Sun Dec 13 19:59:38 UTC 2015
pkgbase = backintime
pkgver = 1.1.8
- pkgrel = 2
+ pkgrel = 3
url = https://launchpad.net/backintime
arch = any
license = GPL
@@ -11,7 +11,7 @@ pkgbase = backintime
source = Fix_bug_473-AttributeError.patch
source = https://launchpadlibrarian.net/219057575/backintime-1.1.8.tar.gz.asc
sha256sums = a1f2d210e95633dfe383eb50b3b560d1e09c43de4ce89dd4cb193cab40cb8a1e
- sha256sums = 100248615c15ae277fee4ee7f27b87d85a4f1d964abd540005803da18ee0870e
+ sha256sums = 281b75fa6726e621b8ecabe8310b7e9e126848eb2215082df38fdf2cbdc52786
sha256sums = SKIP
pkgname = backintime
diff --git a/Fix_bug_473-AttributeError.patch b/Fix_bug_473-AttributeError.patch
index 66a094cec4da..2af4c9561cc5 100644
--- a/Fix_bug_473-AttributeError.patch
+++ b/Fix_bug_473-AttributeError.patch
@@ -1,28 +1,31 @@
---- a/common/config.py 2015-09-28 16:20:10.000000000 -0400
-+++ b/common/config.py 2015-12-13 13:17:53.828658802 -0500
-@@ -28,8 +28,8 @@ except ImportError:
+=== modified file 'common/config.py'
+--- common/config.py 2015-09-28 20:19:24 +0000
++++ common/config.py 2015-12-13 19:32:09 +0000
+@@ -28,8 +28,8 @@
import getpass
pwd = None
--import configfile
- import tools
-+import configfile
++import tools
+ import configfile
+-import tools
import logger
import mount
import sshtools
---- a/common/tools.py 2015-09-28 16:20:10.000000000 -0400
-+++ b/common/tools.py 2015-12-13 13:19:51.636515881 -0500
-@@ -1169,5 +1169,13 @@ class SetupUdev(object):
+
+=== modified file 'common/tools.py'
+--- common/tools.py 2015-08-23 22:21:04 +0000
++++ common/tools.py 2015-12-13 19:31:42 +0000
+@@ -1169,5 +1169,13 @@
return
self.iface.clean()
--if keyring is None and keyring_warn:
-+ def __log_keyring_warning():
++def __log_keyring_warning():
+ from time import sleep
+ sleep(0.1)
- logger.warning('import keyring failed')
++ logger.warning('import keyring failed')
+
-+if keyring is None and keyring_warn:
+ if keyring is None and keyring_warn:
+- logger.warning('import keyring failed')
+ #delay warning to give logger some time to import
+ import _thread
+ _thread.start_new_thread(__log_keyring_warning, ())
diff --git a/PKGBUILD b/PKGBUILD
index 7793767ce5a1..5198a64314d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=('backintime' 'backintime-cli')
_pkgname="backintime"
pkgver=1.1.8
-pkgrel=2
+pkgrel=3
arch=('any')
url="https://launchpad.net/backintime"
license=('GPL')
@@ -14,7 +14,7 @@ source=("https://launchpadlibrarian.net/$_stupidnumber/$_pkgname-$pkgver.tar.gz"
"Fix_bug_473-AttributeError.patch"
"https://launchpadlibrarian.net/$((_stupidnumber + 1))/$_pkgname-$pkgver.tar.gz.asc")
sha256sums=('a1f2d210e95633dfe383eb50b3b560d1e09c43de4ce89dd4cb193cab40cb8a1e'
- '100248615c15ae277fee4ee7f27b87d85a4f1d964abd540005803da18ee0870e'
+ '281b75fa6726e621b8ecabe8310b7e9e126848eb2215082df38fdf2cbdc52786'
'SKIP')
validpgpkeys=('3E70692EE3DB8BDDA5991C90615F366D944B4826') # Germar Reitze
# https://wiki.archlinux.org/index.php/Makepkg#Signature_checking