summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2021-06-04 17:32:55 -0400
committergraysky2021-06-04 17:32:55 -0400
commitdfeb1e460b385369d85562b4c1f21a39103ecc1d (patch)
tree72200a8166b8a05d73897e6401043f4497313b60
parent4c180df3b653997091b3a4513254280ddcbf723e (diff)
downloadaur-dfeb1e460b385369d85562b4c1f21a39103ecc1d.tar.gz
Update to 1.2.1-2
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 15 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 925637ea238c..3fd4c1dfa70e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = backintime
pkgver = 1.2.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/bit-team/backintime
arch = any
license = GPL
makedepends = python
source = backintime-1.2.1.tar.gz::https://github.com/bit-team/backintime/archive/v1.2.1.tar.gz
- sha256sums = b94ecdc6731236d6b640270dbd34ef59c8113c34ac7831de3e8f79eea465786a
+ source = 000-PR-1135.patch::https://github.com/bit-team/backintime/commit/9310acc30362907c7d14f3c8c31a0e4a366d44f5.patch
+ b2sums = a20d22243d7302e4702631b86e4aaf8d1562a485641f11084c5632125eb5be5d52503ad566bcf21d669c4e7a7f9bd4a96b5c47718714cb5fd96fe53c40d2433d
+ b2sums = 54447b266f1eaa871246e009cf1061d61f4eb612146728b8f637a442b58001990e31bbaf93270f6f594a794b0c188d77dd63a62ec35a58ba836cd043999fb5e5
pkgname = backintime
pkgdesc = Simple backup system inspired from the Flyback Project and TimeVault. QT5 GUI version.
@@ -32,4 +34,3 @@ pkgname = backintime-cli
optdepends = encfs: encrypted filesystem in user-space
optdepends = pm-utils: for laptops allows an option to not snapshot on battery
optdepends = sshfs: FUSE client based on the ssh file transfer protocol
-
diff --git a/PKGBUILD b/PKGBUILD
index 01fc42fa5690..233ee8a13d09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,22 @@
pkgname=('backintime' 'backintime-cli')
_pkgname="backintime"
pkgver=1.2.1
-pkgrel=1
+pkgrel=2
arch=('any')
url="https://github.com/bit-team/backintime"
license=('GPL')
makedepends=('python')
#source=("https://github.com/bit-team/$_pkgname/archive/v$pkgver.tar.gz")
-source=("$_pkgname-$pkgver.tar.gz::https://github.com/bit-team/$_pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('b94ecdc6731236d6b640270dbd34ef59c8113c34ac7831de3e8f79eea465786a')
+source=("$_pkgname-$pkgver.tar.gz::https://github.com/bit-team/$_pkgname/archive/v$pkgver.tar.gz"
+ 000-PR-1135.patch::https://github.com/bit-team/backintime/commit/9310acc30362907c7d14f3c8c31a0e4a366d44f5.patch
+)
+b2sums=('a20d22243d7302e4702631b86e4aaf8d1562a485641f11084c5632125eb5be5d52503ad566bcf21d669c4e7a7f9bd4a96b5c47718714cb5fd96fe53c40d2433d'
+ '54447b266f1eaa871246e009cf1061d61f4eb612146728b8f637a442b58001990e31bbaf93270f6f594a794b0c188d77dd63a62ec35a58ba836cd043999fb5e5')
+
+prepare() {
+ cd "$_pkgname-$pkgver"
+ patch -Np1 -i ../000-PR-1135.patch
+}
build() {
cd "$_pkgname-$pkgver/common"