summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122021-07-21 11:20:45 +0200
committerwillemw122021-07-21 11:20:45 +0200
commit6057e16661c48df545fa2fc7761736abafbc07ec (patch)
treefd4c7cd513892880ba02bec13bd1ecd51e3b0ed6
parentde28e1e4591912563cd27d40632dbac3bac6aceb (diff)
downloadaur-6057e16661c48df545fa2fc7761736abafbc07ec.tar.gz
Add checkdepend python-pyqt5
Add comment in check() about isolating integration tests.
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46ac8f7fb9a2..06237ba2cc32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,6 +4,7 @@ pkgbase = backintime-git
url = https://github.com/bit-team/backintime
arch = any
license = GPL
+ checkdepends = python-pyqt5
makedepends = git
makedepends = openssh
makedepends = python-dbus
diff --git a/PKGBUILD b/PKGBUILD
index 006710a43556..ef1229644fc8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,6 +8,7 @@ url="https://github.com/bit-team/backintime"
license=('GPL')
arch=('any')
makedepends=('git' 'openssh' 'python-dbus' 'python-keyring' 'rsync' 'systemd' 'xorg-xdpyinfo')
+checkdepends=('python-pyqt5')
source=($_pkgname::git+$url.git)
sha256sums=('SKIP')
@@ -26,6 +27,9 @@ build() {
}
check() {
+ #LC_ALL=en_US.UTF-8 make -C $_pkgname/common test
+
+ # Isolate some of the integration tests (~/.ssh/ files, ...)
LC_ALL=en_US.UTF-8 HOME=tmp make -C $_pkgname/common test
rm -rf $_pkgname/common/tmp
}