summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122017-03-27 10:05:54 +0200
committerwillemw122017-03-27 10:05:54 +0200
commit78454743f42f306a09e5737ef7c7385410ecde3b (patch)
tree5e6a2b54d299709dcdaa43b225e650ea1d266dd6
parent5e06cbe1d5427d4db50f8c383946c7ff9c47ccbe (diff)
downloadaur-78454743f42f306a09e5737ef7c7385410ecde3b.tar.gz
Add gocryptfs. Remove deprecated pm-utils. Cleanup conflicts list.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e37a848fbb76..76491620113e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = backintime-git
- pkgver = 1.1.12.r347.gaae32612
+ pkgver = 1.1.12.r370.gc5cfedf5
pkgrel = 1
- url = http://backintime.le-web.org
+ url = https://github.com/bit-team/backintime
arch = any
license = GPL
+ checkdepends = gocryptfs
makedepends = git
makedepends = openssh
makedepends = python-dbus
@@ -22,26 +23,21 @@ pkgname = backintime-git
depends = python-dbus
depends = python-pyqt5
depends = xorg-xdpyinfo
- optdepends = meld: diff tool
optdepends = kompare: diff tool
optdepends = python-secretstorage: store passwords
+ optdepends = meld: diff tool
provides = backintime
conflicts = backintime
- conflicts = backintime-gnome
- conflicts = backintime-gtk
- conflicts = backintime-kde4
- conflicts = backintime-qt4
- conflicts = backintime-qt5
pkgname = backintime-cli-git
pkgdesc = Simple backup/snapshot system inspired by Flyback and TimeVault. CLI version.
- depends = rsync
depends = cron
depends = openssh
depends = python-dbus
depends = python-keyring
+ depends = rsync
optdepends = encfs: encrypted filesystems
- optdepends = pm-utils: power management status check
+ optdepends = gocrypt: encrypted filesystems
optdepends = sshfs: remote filesystems
provides = backintime-cli
conflicts = backintime-cli
diff --git a/PKGBUILD b/PKGBUILD
index ccd82b73d556..f76be3361a9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,13 @@
_pkgname=backintime
pkgname=($_pkgname-git $_pkgname-cli-git)
-pkgver=1.1.12.r347.gaae32612
+pkgver=1.1.12.r370.gc5cfedf5
pkgrel=1
-url="http://backintime.le-web.org"
+url="https://github.com/bit-team/backintime"
license=('GPL')
arch=('any')
makedepends=('git' 'openssh' 'python-dbus' 'python-keyring' 'rsync' 'systemd' 'xorg-xdpyinfo')
+checkdepends=('gocryptfs')
source=($_pkgname::git://github.com/bit-team/backintime.git)
md5sums=('SKIP')
@@ -33,9 +34,9 @@ check() {
package_backintime-cli-git() {
pkgdesc="Simple backup/snapshot system inspired by Flyback and TimeVault. CLI version."
- depends=('rsync' 'cron' 'openssh' 'python-dbus' 'python-keyring')
+ depends=('cron' 'openssh' 'python-dbus' 'python-keyring' 'rsync')
optdepends=('encfs: encrypted filesystems'
- 'pm-utils: power management status check'
+ 'gocrypt: encrypted filesystems'
'sshfs: remote filesystems')
provides=($_pkgname-cli)
conflicts=($_pkgname-cli)
@@ -48,10 +49,11 @@ package_backintime-git() {
pkgdesc="Simple backup/snapshot system inspired by Flyback and TimeVault. Qt5 GUI version."
#depends=('backintime-cli' 'libnotify' 'polkit' 'python-dbus' 'python-pyqt5' 'xorg-xdpyinfo')
depends=('backintime-cli-git' 'libnotify' 'polkit' 'python-dbus' 'python-pyqt5' 'xorg-xdpyinfo')
- optdepends=('meld: diff tool' 'kompare: diff tool'
- 'python-secretstorage: store passwords')
+ optdepends=('kompare: diff tool'
+ 'python-secretstorage: store passwords'
+ 'meld: diff tool')
provides=($_pkgname)
- conflicts=($_pkgname $_pkgname-gnome $_pkgname-gtk $_pkgname-kde4 $_pkgname-qt4 $_pkgname-qt5)
+ conflicts=($_pkgname)
cd $_pkgname/qt
make DESTDIR="$pkgdir" install