summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2016-04-17 01:36:09 +0200
committeraksr2016-04-17 01:36:09 +0200
commit06fdc0c8e97e4a414fd2231100f88c947f73e919 (patch)
tree061206a86cd1592e861fea8ed2c12d7f87e2c8cb
downloadaur-backupfs.tar.gz
Start.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD46
-rw-r--r--backupfs.install17
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..99a1181f8ab9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sat Apr 16 23:36:08 UTC 2016
+pkgbase = backupfs
+ pkgdesc = A network extended command level clone of the Plan 9 dump file system.
+ pkgver = 1.0beta10
+ pkgrel = 1
+ url = https://sourceforge.net/projects/backupfs/
+ install = backupfs.install
+ arch = i386
+ arch = x86_64
+ license = BSD
+ conflicts = backupfs-git
+ source = http://downloads.sourceforge.net/sourceforge/backupfs/backupfs-1.0beta10.tar.bz2
+ md5sums = ad488ee255c5aad28fd987a28913f296
+ sha1sums = edd01eb43f5c0ba04ab143c72ae38ea9229cd0aa
+ sha256sums = c610a35b3a8e1d0c8b9fdbda33c6e7049d865bf4beafe3c5a90e253a97410168
+
+pkgname = backupfs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..effd05aab01f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=backupfs
+pkgver=1.0beta10
+pkgrel=1
+epoch=
+pkgdesc="A network extended command level clone of the Plan 9 dump file system."
+arch=('i386' 'x86_64')
+url="https://sourceforge.net/projects/backupfs/"
+license=('BSD')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=('backupfs-git')
+replaces=()
+backup=()
+install=${pkgname}.install
+changelog=
+source=("http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2")
+options=()
+noextract=()
+md5sums=('ad488ee255c5aad28fd987a28913f296')
+sha1sums=('edd01eb43f5c0ba04ab143c72ae38ea9229cd0aa')
+sha256sums=('c610a35b3a8e1d0c8b9fdbda33c6e7049d865bf4beafe3c5a90e253a97410168')
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ sed -i '156,164'd Makefile
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make CC='gcc -m32'
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ mkdir -p $pkgdir/usr/{bin,/share/man}
+ make PREFIX="$pkgdir/usr" TGTGRP="root" MANDIR="$pkgdir/usr/share/man" install
+ install -Dm644 cron.daily-backup.sh $pkgdir/usr/share/doc/$pkgname/cron.daily-backup.sh
+ install -Dm644 INSTALL $pkgdir/usr/share/doc/$pkgname/README
+ install -Dm644 BUGS $pkgdir/usr/share/doc/$pkgname/BUGS
+}
+
diff --git a/backupfs.install b/backupfs.install
new file mode 100644
index 000000000000..65e1b33eb6c9
--- /dev/null
+++ b/backupfs.install
@@ -0,0 +1,17 @@
+post_install() {
+ egrep backupfs /etc/group >/dev/null || groupadd -g 65530 backupfs
+ egrep backupfs /etc/passwd >/dev/null || \
+ useradd -u 65530 -g 65530 -d /home/backupfs -s /usr/bin/backupfs-shell -c 'backupfs, daily backup system' backupfs
+ chown backupfs:backupfs /usr/bin/{backupfs,backupfs{-remote,-chksrc,-exctar,-mkdir,-mklink,-addfiles,-shell,-hist}}
+ chown backupfs:backupfs /usr/bin/newfiles
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ sed -i '/backupfs:x:65530:/d' etc/group
+ sed -i '/backupfs:x:65530:/d' etc/passwd
+}
+