summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Grosch (GNS Systems GmbH)2017-03-27 09:15:43 +0200
committerTobias Grosch (GNS Systems GmbH)2017-03-27 09:15:43 +0200
commit04a82bf71ff4d0969b2357acfa5ff00d25b81a68 (patch)
tree47caa48321b339baa415c154e842da265e7830d9
downloadaur-04a82bf71ff4d0969b2357acfa5ff00d25b81a68.tar.gz
initial commit for bacula 5.2.13
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD49
-rw-r--r--bacula-fd.service19
3 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51df264e1123
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = bacula-client
+ pkgdesc = A network backup tool for Linux, Unix, Mac and Windows - client edition
+ pkgver = 5.2.13
+ pkgrel = 1
+ url = http://www.bacula.org/
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ license = GPL2
+ depends = openssl
+ provides = bacula-fd=5.2.13
+ conflicts = bacula
+ backup = etc/bacula/bconsole.conf
+ backup = etc/bacula/bacula-fd.conf
+ source = http://downloads.sourceforge.net/project/bacula/bacula/5.2.13/bacula-5.2.13.tar.gz
+ source = bacula-fd.service
+ sha256sums = a4bed458bf001889bd06bf31671b5d9908055a1d1e8113fd750ae4d326607ad8
+ sha256sums = 37cdab95a99142a7e8494f0a49e54a5bfb1dca28561d0ce70ea64bf98e0c50fd
+
+pkgname = bacula-client
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..255779a0a16d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+# Contributor: Arian <arian.sameni+bacula-client AT gmail DOT com>
+# Contributor: Xavion <Xavion (dot) 0 (at) Gmail (dot) com>
+# Contributor: Matthew <pyther@pyther.net>
+
+pkgname=bacula-client
+pkgver=5.2.13
+pkgrel=1
+pkgdesc='A network backup tool for Linux, Unix, Mac and Windows - client edition'
+conflicts=('bacula')
+depends=('openssl')
+provides=("bacula-fd=${pkgver}")
+arch=('i686' 'x86_64' 'arm' 'armv6h')
+url='http://www.bacula.org/'
+license=('GPL2')
+backup=('etc/bacula/bconsole.conf'
+ 'etc/bacula/bacula-fd.conf')
+# verification fails for DSA signatures, so disabled for now...
+#validpgpkeys=('2CA9F510CA5CCAF61AB529F59E98BF3210A792AD') # Bacula Distribution Verification Key (www.bacula.org)
+source=("http://downloads.sourceforge.net/project/bacula/bacula/${pkgver}/bacula-${pkgver}.tar.gz" #{,.sig}
+ 'bacula-fd.service')
+sha256sums=('a4bed458bf001889bd06bf31671b5d9908055a1d1e8113fd750ae4d326607ad8'
+ '37cdab95a99142a7e8494f0a49e54a5bfb1dca28561d0ce70ea64bf98e0c50fd')
+
+build() {
+ cd bacula-${pkgver}/
+
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --enable-client-only \
+ --with-systemd=/usr/lib/systemd/system/ \
+ --with-openssl \
+ --sysconfdir=/etc/bacula \
+ --with-scriptdir=/etc/bacula/scripts
+
+ make
+}
+
+package() {
+ cd bacula-${pkgver}/
+
+ make DESTDIR="${pkgdir}" install
+
+ # we do not take the service file provided by bacula package
+ # as it needs too much customization
+ install -D -m0644 "${srcdir}/bacula-fd.service" "${pkgdir}/usr/lib/systemd/system/bacula-fd.service"
+}
+
diff --git a/bacula-fd.service b/bacula-fd.service
new file mode 100644
index 000000000000..90bd6a9ab36a
--- /dev/null
+++ b/bacula-fd.service
@@ -0,0 +1,19 @@
+# systemd service file for Bacula File Deaemon
+#
+# we do not take the service file provided by bacula package as it needs too
+# much customization
+
+[Unit]
+Description=Bacula File Deaemon
+Requires=network.target
+After=network.target remote-fs.target syslog.target
+
+[Service]
+Type=forking
+Restart=always
+ExecStart=/usr/bin/bacula-fd -c /etc/bacula/bacula-fd.conf
+IOSchedulingClass=idle
+PIDFile=/run/bacula-fd.9102.pid
+
+[Install]
+WantedBy=multi-user.target