summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkpcyrd2018-03-15 23:43:00 +0100
committerkpcyrd2018-03-15 23:43:00 +0100
commit21df5443b1607f10eccd2ed21809ed153ddf1eb9 (patch)
tree1677164b8f5829cc27ac96cc9591e899f29d1809
downloadaur-21df5443b1607f10eccd2ed21809ed153ddf1eb9.tar.gz
v0.1.0-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD39
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aa76f0418b68
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = badtouch-git
+ pkgdesc = Scriptable network authentication cracker
+ pkgver = 0.1.0.r0.g5a7a2d4
+ pkgrel = 1
+ url = https://github.com/kpcyrd/badtouch
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = aarch64
+ license = GPL3
+ makedepends = cargo
+ makedepends = git
+ depends = gcc-libs
+ provides = badtouch
+ conflicts = badtouch
+ source = git+https://github.com/kpcyrd/badtouch.git
+ sha512sums = SKIP
+
+pkgname = badtouch-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27aa27ecf37c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: kpcyrd <git@rxv.cc>
+
+_gitname=badtouch
+pkgname=badtouch-git
+pkgver=0.1.0.r0.g5a7a2d4
+pkgrel=1
+pkgdesc="Scriptable network authentication cracker"
+url="https://github.com/kpcyrd/badtouch"
+depends=('gcc-libs')
+makedepends=('cargo' 'git')
+provides=('badtouch')
+conflicts=('badtouch')
+arch=('i686' 'x86_64' 'armv6h' 'aarch64')
+license=('GPL3')
+source=("git+https://github.com/kpcyrd/$_gitname.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_gitname"
+ cargo build --release
+}
+
+check() {
+ cd "$_gitname"
+ cargo test --release
+}
+
+package() {
+ cd "$_gitname"
+ install -Dm755 "target/release/$_gitname" -t "$pkgdir/usr/bin"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$_gitname"
+}
+
+# vim:set ts=2 sw=2 et: