summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarren Ng2021-03-21 19:54:53 +0800
committerDarren Ng2021-03-21 19:54:53 +0800
commit28e6eba1c4421a4a8791236b1c7a6201bb6266bf (patch)
treeed5a876e0c1727ff622a11f9e9e77a15f14ba3af
parent38ac1b9a7765b6bd72a1d834bb6f02f2409aa490 (diff)
downloadaur-28e6eba1c4421a4a8791236b1c7a6201bb6266bf.tar.gz
do not rely on transitive dependencies
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD22
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba6bd45e86e2..33814cb8b9f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = badvpn-git
pkgdesc = NCD scripting language, tun2socks proxifier, P2P VPN
pkgver = r1949.4b7070d
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ambrop72/badvpn
arch = x86_64
license = custom:BSD-3-Clause
makedepends = git
makedepends = cmake
- makedepends = time
+ depends = nspr
depends = nss
+ depends = openssl
provides = badvpn
conflicts = badvpn
conflicts = tun2socks
diff --git a/PKGBUILD b/PKGBUILD
index 089ba62241ab..6a8bfd845ec4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,18 @@
-# Maintainer: Darren Ng <$(base64 --decode <<<'VW4xR2ZuQGdtYWlsLmNvbQo=')>
+# Maintainer: Darren Ng <$(base64 --decode <<<VW4xR2ZuQGdtYWlsLmNvbQo=)>
pkgname=badvpn-git
pkgver=r1949.4b7070d
-pkgrel=1
+pkgrel=2
pkgdesc="NCD scripting language, tun2socks proxifier, P2P VPN"
arch=($CARCH)
url=https://github.com/ambrop72/${pkgname%-git}
-license=(custom:BSD-3-Clause) # https://spdx.org/licenses/
-# NSPR_INCLUDE_DIRS /usr/include/nspr
-# nspr -> nss -> badvpn-git
-# openssl -> base
-depends=(nss)
-makedepends=(git cmake time)
+# https://spdx.org/licenses/
+license=(custom:BSD-3-Clause)
+# https://wiki.archlinux.org/index.php/Arch_package_guidelines#Package_dependencies
+# Do not rely on transitive dependencies
+depends=(nspr nss openssl)
+makedepends=(git cmake)
provides=(${pkgname%-git})
conflicts=(${pkgname%-git} tun2socks{,-git})
-# backup=() # systemd service file?
source=(${pkgname%-git}::git+https://github.com/ambrop72/${pkgname%-git}.git#branch=master)
md5sums=(SKIP)
@@ -45,13 +44,14 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DWITH_PLUGIN_LIBS=ON \
\
- -DCMAKE_INSTALL_LIBEXECDIR=lib \
+ -DCMAKE_INSTALL_LIBEXECDIR="lib/${pkgname%-git}/" \
-DCMAKE_INSTALL_SBINDIR=bin
# ccmake -B build -S .
# echo; pwd; echo; return 1
- /usr/bin/time --format="\n wall clock time - %E\n" make -C build
+ # /usr/bin/time --format="\n wall clock time - %E\n" \
+ make -C build
}