summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLéo2023-09-19 21:18:36 +0200
committerLéo2023-09-19 21:18:36 +0200
commit1e0eedc69d49c326c907f81289b41c92b18515d2 (patch)
tree25d41d47b57ffd9e06cf277dc4bec192ca9e350b
parent37aff4ce790f674f164191a980f411fedd85d9f8 (diff)
downloadaur-badwolf.tar.gz
Bump to 1.3.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD16
-rw-r--r--changelog103
3 files changed, 112 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9013d88b174a..0348640dcaca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = badwolf
pkgdesc = A minimalist and privacy-oriented WebKitGTK+ browser.
- pkgver = 1.2.2
- pkgrel = 2
+ pkgver = 1.3.0
+ pkgrel = 1
url = https://hacktivis.me/projects/badwolf
+ changelog = changelog
arch = i686
arch = x86_64
arch = armv7h
arch = aarch64
license = BSD
+ makedepends = ninja
+ makedepends = ed
depends = webkit2gtk
- source = https://hacktivis.me/releases/badwolf-1.2.2.tar.gz
- sha512sums = 0f7bd28ab9bae51323082bad172914009ba979cc9f990a782f7f032ca65589284708ffcaa530f737ecd3d00b580000988b5d18fbb2643ce0df3bc001a58ef611
- changelog = changelog
+ depends = libxml2
+ source = https://hacktivis.me/releases/badwolf-1.3.0.tar.gz
+ sha512sums = f83884f9a1c4d12d641f68697d7fab7885803975ead6cb78e88b0b8d2f7b6f9da116f72e39f02c47e8dca89e4ced9b932524338a6211c7d4509c12206c10cdeb
pkgname = badwolf
-
diff --git a/PKGBUILD b/PKGBUILD
index 7cad2d6baa7a..86fda37dab1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
-# Maintainer: Leia <waste at mrtino dot eu>
+# Maintainer: Léo <waste at mrtino dot eu>
pkgname=badwolf
-pkgver=1.2.2
-pkgrel=2
+pkgver=1.3.0
+pkgrel=1
pkgdesc="A minimalist and privacy-oriented WebKitGTK+ browser."
url="https://hacktivis.me/projects/badwolf"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
license=('BSD')
-#makedepends=('clang') # if you want to use clang instead of gcc, decomment this line and change CC=gcc to CC=clang in the build section
-depends=('webkit2gtk')
+makedepends=('ninja' 'ed')
+depends=('webkit2gtk' 'libxml2')
source=("https://hacktivis.me/releases/$pkgname-$pkgver.tar.gz")
-sha512sums=('0f7bd28ab9bae51323082bad172914009ba979cc9f990a782f7f032ca65589284708ffcaa530f737ecd3d00b580000988b5d18fbb2643ce0df3bc001a58ef611')
+sha512sums=('f83884f9a1c4d12d641f68697d7fab7885803975ead6cb78e88b0b8d2f7b6f9da116f72e39f02c47e8dca89e4ced9b932524338a6211c7d4509c12206c10cdeb')
changelog=changelog
build() {
cd "$pkgname-$pkgver"
PREFIX=/usr ./configure
- make
+ ninja
}
package() {
cd "$pkgname-$pkgver"
install -Dm644 COPYING -t "$pkgdir/usr/share/licenses/$pkgname"
- make PREFIX=/usr DESTDIR="$pkgdir/" install
+ DESTDIR="${pkgdir}/" ninja install
}
diff --git a/changelog b/changelog
index b86c05e0a1b3..1a63dae43e44 100644
--- a/changelog
+++ b/changelog
@@ -1,12 +1,101 @@
-Badwolf 1.2.2 release! - 2021-11-21
+Badwolf 1.3.0 release! - 2023-09-19
-I just screwed the 1.2.1 release with forgetting to bump the version
-(and putting a wrong date in the notes).
-Gonna fix it for future releases via writing scripts to avoid another PEBKAC.
+User Highlights
+===============
+
+Additions
+---------
+- Support for translated manpages (German, French, Turkish, Vietnamese)
+- Add basic (no domain/URL matching yet) UserScripts support
+- Middle-clicks and ctrl+click opens links in a new tab
+
+Fixes
+-----
+- WebProcess crashes do not clear the URL entry anymore
+- Do not set web-context when old_browser is present.
+ This fixes crashes with WebKitGTK 2.41+
Commits
=======
+Ben K (1):
+ Updated German translation and added German manpage
+
+Haelwenn (lanodan) Monnier (70):
+ configure: Parse arguments for variables
+ configure: Allow WITH_* variables, describe dependencies
+ configure: Simplify argument parsing
+ test: Add shellcheck
+ Move linting to own `lint` target
+ fmt: Grab fmt_context_id for tests
+ configure: Add support for LDFLAGS
+ Add static analysis via flawfinder(1)
+ Makefile: Move cleaning config.mk to distclean target
+ bookmark_test: Add basic test
+ uri: Remove access() check
+ configure: Set FLAWFINDER in config.mk
+ .builds: Add CI (NetBSD, OpenBSD)
+ badwolf.1: Change forge to sr.ht
+ badwolf.fr.1: Introduce translated manpage
+ Use po4a for manpage translation
+ fmt_test: Fix uint64_t literal and printing
+ Make repository reuse compliant
+ .builds: Add po4a in the packages
+ Unbreak gnome.org documentation links
+ po: Remove location information, disable wrapping of long lines
+ Replace casts to (void) to UNUSED macro
+ decisions: 2021-09-07 : Move to a ./configure script
+ .clang-format: AllowShortCaseLabelsOnASingleLine: false
+ configure: Fix lack of newline for disabled commands
+ badwolf: Fix compilation issue with clang
+ Update email of Oğuz Ersen
+ badwolf.1: Document GTK ctrl-;
+ Manpages: Add note on lack of XBEL sorting
+ Add UserScripts support
+ userscripts: Handle g_file_get_contents errors
+ manpage: Note the lack of GM-style userscript filtering
+ Don't change URI on WebProcess termination
+ Don't change Title on WebProcess termination
+ Improve handling of intentionally empty title
+ userscripts: Improve error messages
+ badwolf: webkit_web_view_get_title returns a const
+ badwolf: Remove deprecated webkit_web_context_set_process_model
+ Move from make(1) to ninja/samurai
+ README: Remove mention of OpenPGP
+ configure: Fix ED and FLAWFINDER variables
+ configure: Use po4a-updatepo when po file already exists
+ configure: Add icons, trans_man, bundled, fullclean targets
+ badwolf.tr.1: Bundle
+ .gitignore: ./*_test and ./install.sh
+ userscripts: Formatting fix
+ .build: Ditch po4a
+ .builds: Make sure git works
+ .builds/openbsd: webkitgtk4 → webkitgtk41
+ configure: Replace ${var//./.} with sed
+ .builds: Separate split ninja clean all in two cmds
+ po/tr_man.po: Fix syntax error due to ASCII apostrophe
+ configure: Fix newins() argument extraction
+ config.h: Update documentation URL
+ config.h: Remove deprecated enable-accelerated-2d-canvas
+ configure: Add vi in TRANS_MAN
+ po/vi.po: Add missing newline
+ decisions: Switch from Makefile to *.ninja
+ po/de*: Add missing copyright headers
+ .builds/netbsd.yml: Add xz package for now
+ .builds/netbsd.yml: ninja is called ninja-build on NetBSD
+ configure: Check and allow changing msgmerge and xgettext
+ configure: Check for xgettext --package-name=
+ Do not set web-context when old_browser is present
+ configure: Move -D_FORTIFY_SOURCE=2 to default and drop non-standard feature flags
+ Release 1.3.0
+ Merge branch 'release-1.3' into missy
+
+Ngô Ngọc Đức Huy (1):
+ Update Vietnamese translation and manpage
+
+Oğuz Ersen (2):
+ po: update Turkish translation
+ doc: fix typos
-Haelwenn (lanodan) Monnier (2):
- Bump to 1.2.2
- Merge branch 'release-1.2' into missy for 1.2.2
+Stacy Harper (2):
+ badwolf.c: add ctrl+click to open link in new tab
+ badwolf.c: add mouse middle click to open link in new tab