summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeia2021-10-04 11:03:14 +0200
committerLeia2021-10-04 11:03:14 +0200
commitc256ee80cf0f65cd41de740261c9e795601f22e6 (patch)
treef8fad1a188a370bff9534ee9791bf1f95dc9d5f2
parent8197480d0e0fab56465c85c67f095f8ccc4de312 (diff)
downloadaur-c256ee80cf0f65cd41de740261c9e795601f22e6.tar.gz
Cleanup
-rw-r--r--.SRCINFO8
-rw-r--r--LICENSE29
-rw-r--r--PKGBUILD22
-rw-r--r--arch.patch10
-rw-r--r--badwolf.install9
-rw-r--r--changelog54
6 files changed, 64 insertions, 68 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54f71aa31019..31719584918c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
pkgbase = badwolf
- pkgdesc = A minimalist and privacy-oriented WebKit browser.
+ pkgdesc = A minimalist and privacy-oriented WebKitGTK+ browser.
pkgver = 1.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://hacktivis.me/projects/badwolf
- install = badwolf.install
arch = i686
arch = x86_64
arch = armv7h
license = BSD
depends = webkit2gtk
source = https://hacktivis.me/releases/badwolf-1.2.0.tar.gz
- source = LICENSE
sha512sums = ccf0eb25630438ba783ae7e6d30b0c516290966199bbe36f76b22f2091c3a2940676ee0fb0a5cf46a9cb258e7979084d6f34662f7252c1b37ec0cee7c9958fb0
- sha512sums = 9a3b68429fc2267d596e08671330cc81f6d00ac7217a7a3991ebb583823a13e323108b514f5ec672c0982844ec581d9fed28dfede8fd92976b41d46b2924e140
+ changelog = changelog
pkgname = badwolf
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 29606df55a55..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,29 +0,0 @@
-BSD 3-Clause License
-
-Copyright (c) 2019-2020, Badwolf Authors <https://hacktivis.me/projects/badwolf>
-All rights reserved.
-
-Redistribution and use in source and binary forms, with or without
-modification, are permitted provided that the following conditions are met:
-
-1. Redistributions of source code must retain the above copyright notice, this
- list of conditions and the following disclaimer.
-
-2. Redistributions in binary form must reproduce the above copyright notice,
- this list of conditions and the following disclaimer in the documentation
- and/or other materials provided with the distribution.
-
-3. Neither the name of the copyright holder nor the names of its
- contributors may be used to endorse or promote products derived from
- this software without specific prior written permission.
-
-THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
-AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
-IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
-DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
-FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
-DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
-SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
-CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
-OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
index 2889d0949e20..15519dcd4d55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,16 @@
pkgname=badwolf
pkgver=1.2.0
-pkgrel=1
-pkgdesc="A minimalist and privacy-oriented WebKit browser."
+pkgrel=2
+pkgdesc="A minimalist and privacy-oriented WebKitGTK+ browser."
url="https://hacktivis.me/projects/badwolf"
arch=('i686' 'x86_64' 'armv7h')
-license=('BSD')
+license=('custom')
#makedepends=('clang') # if you want to use clang instead of gcc, decomment this line and change CC=gcc to CC=clang in the build section
depends=('webkit2gtk')
-source=("https://hacktivis.me/releases/$pkgname-$pkgver.tar.gz"
- "LICENSE")
-sha512sums=('ccf0eb25630438ba783ae7e6d30b0c516290966199bbe36f76b22f2091c3a2940676ee0fb0a5cf46a9cb258e7979084d6f34662f7252c1b37ec0cee7c9958fb0'
- '9a3b68429fc2267d596e08671330cc81f6d00ac7217a7a3991ebb583823a13e323108b514f5ec672c0982844ec581d9fed28dfede8fd92976b41d46b2924e140')
-install=badwolf.install
-
-#prepare() {
-# cd "$pkgname-${pkgver//_/-}"
-# # In order to be compliant with Arch Linux directory guidelines
-# patch -p1 -i "$srcdir/arch.patch"
-#}
+source=("https://hacktivis.me/releases/$pkgname-$pkgver.tar.gz")
+sha512sums=('ccf0eb25630438ba783ae7e6d30b0c516290966199bbe36f76b22f2091c3a2940676ee0fb0a5cf46a9cb258e7979084d6f34662f7252c1b37ec0cee7c9958fb0')
+changelog=changelog
build() {
cd "$pkgname-$pkgver"
@@ -28,7 +20,7 @@ build() {
}
package() {
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 COPYING -t "$pkgdir/usr/share/licenses/$pkgname"
cd "$pkgname-$pkgver"
make PREFIX=/usr DESTDIR="$pkgdir/" install
}
diff --git a/arch.patch b/arch.patch
deleted file mode 100644
index 2a7701f54147..000000000000
--- a/arch.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/Makefile 2019-07-05 08:31:23.000000000 +0200
-+++ b/Makefile 2019-08-18 15:02:02.175775084 +0200
-@@ -1,6 +1,6 @@
- .POSIX:
-
--PREFIX ?= /usr/local
-+PREFIX ?= /usr
- BINDIR ?= $(PREFIX)/bin
- MANDIR ?= $(PREFIX)/share/man
- DATADIR ?= $(PREFIX)/share/badwolf
diff --git a/badwolf.install b/badwolf.install
deleted file mode 100644
index ce6970892bcf..000000000000
--- a/badwolf.install
+++ /dev/null
@@ -1,9 +0,0 @@
-post_install() {
- echo "-- If you want to modify config.h (which has some GUI and WebKit parameters), you can do so by accessing the build directory (directory location varies depending on how you built it, e.g with makepkg or yay). --"
- /bin/true
-}
-
-post_upgrade() {
- echo "-- Badwolf 1.2.0 changelog: https://hacktivis.me/releases/badwolf-1.2.0.txt --"
- /bin/true
-}
diff --git a/changelog b/changelog
new file mode 100644
index 000000000000..b4060bbf01fe
--- /dev/null
+++ b/changelog
@@ -0,0 +1,54 @@
+Badwolf 1.2.0 release! — 2021-10-02
+
+Highlights
+==========
+
+Additions
+---------
+- Middle clicking on a tab now closes it
+- Translations: Vietnamese
+
+Changes
+-------
+- This release introduces a ./configure script, it isn't autotools-like,
+ it takes environment variables as configuration overrides and writes
+ the results to config.mk
+- Drop usage of libsoup URI parser in favor of GLib's GUri
+
+Fixes
+-----
+- webkit2gtk-4.1 (WebKit GTK+3.0 port with libsoup3) compatibility
+- WebKitGTK 2.34.0+, requiring GApplication initialization
+- Manpage: Some tags were off, apparently leading to broken formatting
+- crashes: download stop icon, about dialog
+
+Commits
+=======
+
+Haelwenn (lanodan) Monnier (19):
+ downloads: Destroy stop_icon only in downloadCb_finished
+ badwolf.1: Fix extension path
+ about-dialog: Auto-switch, use gtk_window_close
+ Makefile: Add EXTRA_CFLAGS
+ badwolf.1: Add tip to list dictionairies in enchant
+ Makefile: Force some cflags, bump _XOPEN_SOURCE to 700
+ README.md: FreeNode → GeekNode
+ badwolf.h: Add WEBKIT_CHECK_VERSION
+ Change buildsystem to use a ./configure script
+ Initialize a GApplication
+ Switch from libsoup-2.4 to glib's GUri
+ Hook and fixup Vietnamese translation
+ badwolf.1: Fix problems seen with mandoc -Tlint
+ Make: Add manpage linting
+ badwolf.1: Add more details in the FILES section
+ badwolf.1: Fix gtk-doc css-properties URL
+ configure: Fix test case in is_ok
+ Bump to 1.2.0
+ Merge branch 'release-1.2' into missy for 1.2.0
+
+Ngô Ngọc Đức Huy (1):
+ Add Vietnamese translation
+
+striker.sh (1):
+ Close tab when releasing middle mouse click
+