summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGary DeLaney2015-08-11 17:51:56 -0500
committerGary DeLaney2015-08-11 17:51:56 -0500
commit720e9a589a7f6e2b7f3afd0572fd002eed9c1c3b (patch)
treefe4f71947f5a89fa8ffec31e16ca2f770e25e3b1
downloadaur-720e9a589a7f6e2b7f3afd0572fd002eed9c1c3b.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD37
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85219153422e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = bake
+ pkgdesc = An easy to use build system. Designed to be make/autotools for the 21st century. (with Semplice Linux patches)
+ pkgver = 0.1.49
+ pkgrel = 1
+ url = https://launchpad.net/bake
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = itstool
+ makedepends = vala
+ provides = bake
+ conflicts = bake
+ conflicts = bake
+ source = https://launchpad.net/bake/0.1/0.1.49/+download/bake-0.1.49.tar.gz
+ source = https://github.com/semplice/bake/compare/gir_lookup.patch
+ source = https://github.com/semplice/bake/compare/python_version.patch
+ md5sums = 20eda033c1482900da0cccfb90a77f6d
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = bake
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cc67b0b4d0bf
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!*.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe07406f5cdb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: gld1982ltd <gld1982ltd@gmail.com>
+
+pkgname=bake
+pkgver=0.1.49
+pkgrel=1
+pkgdesc="An easy to use build system. Designed to be make/autotools for the 21st century. (with Semplice Linux patches)"
+arch=('i686' 'x86_64')
+url="https://launchpad.net/bake"
+license=("GPL3")
+provides=("${pkgname%-sl}")
+conflicts=("${pkgname%}" "${pkgname%-sl}")
+makedepends=('itstool' 'vala')
+source=("https://launchpad.net/bake/0.1/${pkgver}/+download/bake-${pkgver}.tar.gz"
+ "https://github.com/semplice/bake/compare/gir_lookup.patch"
+ "https://github.com/semplice/bake/compare/python_version.patch"
+)
+md5sums=('20eda033c1482900da0cccfb90a77f6d'
+ 'SKIP'
+ 'SKIP'
+)
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 -i ${srcdir}/gir_lookup.patch
+ patch -p1 -i ${srcdir}/python_version.patch
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+ ./bake-bootstrap --configure install-directory="$pkgdir/"
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./bake-bootstrap install
+}