summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGnarflord2022-02-04 16:29:29 +0100
committerGnarflord2022-02-04 16:29:29 +0100
commitaca920e2646b946330a06d321d43681c28ba9c32 (patch)
tree1214c811652584974a809e0cf3fd139d6e85986b
downloadaur-aca920e2646b946330a06d321d43681c28ba9c32.tar.gz
Initial commit for bakelite
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD32
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..da779894ad18
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = bakelite
+ pkgdesc = Incremental backup with strong cryptographic confidentiality baked into the data model
+ pkgver = r70.9e70abd
+ pkgrel = 1
+ url = https://github.com/richfelker/bakelite
+ arch = x86_64
+ license = GPL2
+ source = git+https://github.com/richfelker/bakelite.git#commit=9e70abd
+ md5sums = SKIP
+
+pkgname = bakelite
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23adbaa99000
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Gnarflord <aur@gnarf.link>
+pkgname=bakelite
+pkgver=r70.9e70abd
+pkgrel=1
+pkgdesc="Incremental backup with strong cryptographic confidentiality baked into the data model"
+arch=('x86_64')
+url="https://github.com/richfelker/bakelite"
+license=('GPL2')
+# Stuck at commit 9e70abd, as package no longer compiles as of 2021-02-04
+# See https://github.com/richfelker/bakelite/issues/2
+source=("git+https://github.com/richfelker/bakelite.git#commit=9e70abd")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "$pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "$pkgname"
+
+ make
+}
+
+package() {
+ cd "$pkgname"
+
+ install -D bakelite "$pkgdir/usr/bin/bakelite"
+}