aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKent Slaney2024-09-12 21:56:49 -0700
committerKent Slaney2024-09-12 21:56:49 -0700
commit50a8d7814343c82e738123b409079d457a34b351 (patch)
treeb8a49d23d122296b83be4e603b4d4eb218063fee
parentcee7dc8d2b812c95f90fa28b0442fcdebabe0953 (diff)
downloadaur-50a8d7814343c82e738123b409079d457a34b351.tar.gz
use wine bin from heroic config if available
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12b38968dce9..b09db0017726 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bakkesmod-legendary
pkgdesc = A mod aimed at making you better at Rocket League!
pkgver = 2.43
- pkgrel = 6
+ pkgrel = 7
url = https://bakkesmod.com/
arch = x86_64
license = GPL
@@ -14,7 +14,7 @@ pkgbase = bakkesmod-legendary
makedepends = jq
source = dll-2-0-43.zip::https://github.com/bakkesmodorg/BakkesModInjectorCpp/releases/download/2.0.43/bakkesmod.zip
source = src-2-0-43.zip::https://github.com/bakkesmodorg/BakkesModInjectorCpp/archive/refs/tags/2.0.43.zip
- source = loopback-2-43-6.zip::https://github.com/kentslaney/bakkesmod-arch/archive/refs/tags/2.43-6-legendary.zip
+ source = loopback-2-43-7.zip::https://github.com/kentslaney/bakkesmod-arch/archive/refs/tags/2.43-7-legendary.zip
source = pwshwrapper-05ea332.zip::https://github.com/PietJankbal/powershell-wrapper-for-wine/archive/05ea332209f52b796a78246a89757a291f254fb6.zip
sha256sums = 3d39b07149872d891659330185ef9c4e02c580bfad67ed2df9979dbd72d4ae61
sha256sums = 2d9cb1534fbae77ba008b07be3291d30e98a872ebfb0f0b3e6bb0c638d98bef8
diff --git a/PKGBUILD b/PKGBUILD
index a5be90e78163..e3094428edb8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Kent Slaney <kent@slaney.org>
pkgname=bakkesmod-legendary
pkgver=2.43
-pkgrel=6
+pkgrel=7
pkgdesc="A mod aimed at making you better at Rocket League!"
arch=('x86_64')
url="https://bakkesmod.com/"
@@ -194,6 +194,7 @@ package() {
# heroic env variables
import json
if not env.is_file():
+ print("wine")
exit(0)
with open(env) as fp:
opt = json.load(fp)
@@ -212,10 +213,14 @@ package() {
if changed:
with open(env, "w") as fp:
json.dump(opt, fp, indent=2)
+ try:
+ print(opt["Sugar"]["wineVersion"]["bin"])
+ except:
+ print("wine")
EOF
)
cfg="$(dirname "$installed")/config.ini"
- PFX="$bm_pfx" FP="$cfg" SUGAR_ENV="$(heroic_env)" python -c "$py"
+ wine_bin=`PFX="$bm_pfx" FP="$cfg" SUGAR_ENV="$(heroic_env)" python -c "$py"`
sed "s/^ \{8\}//" <<" EOF" > "$bm_pfx/runner.py"
import argparse, os, shlex, pathlib
@@ -263,7 +268,10 @@ package() {
ln -sf "$dll_path/bakkesmod_official.dll" "$dll_path/bakkesmod.dll"
cp -f "$srcdir/inject.exe" "$bm_pfx"
- ( cd "$srcdir/powershell-wrapper-for-wine-$pwsh_sum" && WINEPREFIX="$pfx" powershell "wine64" ) 2> /dev/null
+ (
+ cd "$srcdir/powershell-wrapper-for-wine-$pwsh_sum" &&
+ LD_PRELOAD= WINEPREFIX="$pfx" powershell "$wine_bin"
+ ) 2> >(grep --color=NEVER mismatch >&2)
}
pre_remove() {