summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBusindre2017-05-21 21:53:49 +0200
committerBusindre2017-05-21 21:53:49 +0200
commit33ff6cf54a3b442f366df9afdad5258f3328b935 (patch)
tree7d7fabcb5d38eb8f7c4aec03fc6960034c59a8a7
downloadaur-33ff6cf54a3b442f366df9afdad5258f3328b935.tar.gz
Balance AUR
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6ea7df11d27b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = balance
+ pkgdesc = Command line TCP load balancing with round-robin and failover.
+ pkgver = 3.57
+ pkgrel = 1
+ url = https://www.inlab.de/balance.html
+ arch = any
+ license = GPL
+ depends = glibc
+ source = https://www.inlab.de/balance-3.57.tar.gz
+ sha512sums = 191195e2aa62c867d85085f273db911e8957c3eea7bed8e58abc29e125a0b0a4487048c7db5857e32f54545de1f81f8148b174225aaf8cf1e3a66e4b040748b4
+
+pkgname = balance
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..577592eee5fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Busindre <busilezas at gmail dot com>
+
+pkgname=balance
+pkgver=3.57
+pkgrel=1
+pkgdesc='Command line TCP load balancing with round-robin and failover.'
+arch=('any')
+url='https://www.inlab.de/balance.html'
+license=('GPL')
+depends=('glibc')
+source=("https://www.inlab.de/${pkgname}-${pkgver}.tar.gz")
+sha512sums=('191195e2aa62c867d85085f273db911e8957c3eea7bed8e58abc29e125a0b0a4487048c7db5857e32f54545de1f81f8148b174225aaf8cf1e3a66e4b040748b4')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make
+}
+
+package() {
+
+ install -d "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/usr/share/man/man1"
+ install -d "${pkgdir}/run/balance"
+
+ cd ${srcdir}/${pkgname}-${pkgver}
+ install -D -m755 balance ${pkgdir}/usr/bin/
+ install -D -m755 balance.1 ${pkgdir}/usr/share/man/man1/
+ install -d ${pkgdir}/run/balance
+}