summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Stubbs2016-10-31 09:30:49 +0000
committerAndrew Stubbs2016-10-31 09:30:49 +0000
commit02c05353d762cbe6dbaf4c9a8550a4994f891dd9 (patch)
tree99bba9dcac71453212d66fa49733c2dfbec7e72d
parentcea8793a27d0a6e437ac97116fb3edf23eaf8582 (diff)
downloadaur-02c05353d762cbe6dbaf4c9a8550a4994f891dd9.tar.gz
1.0.0-beta.16. New download package required build tweaks.
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 116705c5e594..aea3e4271465 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Andrew Stubbs <andrew.stubbs@gmail.com>
pkgname=etcher
-realver=1.0.0-beta.15
+realver=1.0.0-beta.16
pkgver=${realver//-/_}
pkgrel=1
pkgdesc="Burn images to SD cards & USB drives, safe & easy"
@@ -15,22 +15,21 @@ optdepends=('libnotify: for notifications'
source=("etcher"
"Etcher.desktop"
"etcher.png")
-source_i686=("Etcher-linux-x86-$realver.AppImage::https://resin-production-downloads.s3.amazonaws.com/etcher/$realver/Etcher-linux-x86.AppImage")
-source_x86_64=("Etcher-linux-x64-$realver.AppImage::https://resin-production-downloads.s3.amazonaws.com/etcher/$realver/Etcher-linux-x64.AppImage")
-noextract=("Etcher-linux-x86-$realver.AppImage" "Etcher-linux-x64-$realver.AppImage")
+source_i686=("https://resin-production-downloads.s3.amazonaws.com/etcher/$realver/Etcher-$realver-linux-x86.zip")
+source_x86_64=("https://resin-production-downloads.s3.amazonaws.com/etcher/$realver/Etcher-$realver-linux-x64.zip")
options=("!strip")
md5sums=('8eff5560a3a4cae73698d7eda2d71577'
'89f5cf77f164510b1f980820aaa4cf91'
'7bd70ef05c6293e36938240be2558091')
-md5sums_i686=('8fda47dbda5317d9f643d5c53fccc0d9')
-md5sums_x86_64=('f52b9d2b8597b4abfe1bb6b9662e7928')
+md5sums_i686=('49781df73cb8e075228b9f3874a9c7a6')
+md5sums_x86_64=('cc248864a673450827757021a0df0cd7')
package() {
local a=x86
[ "$pkgarch" == "x86_64" ] && a=x64
install -D "$srcdir/etcher" "$pkgdir/usr/bin/etcher"
- install -D "$srcdir/Etcher-linux-$a-$realver.AppImage" "$pkgdir/usr/share/etcher/Etcher-linux-$a.AppImage"
+ install -D "Etcher-linux-$a.AppImage" "$pkgdir/usr/share/etcher/Etcher-linux-$a.AppImage"
install --mode=644 -D "$srcdir/etcher.png" "$pkgdir/usr/share/etcher/etcher.png"
install -D "$srcdir/Etcher.desktop" "$pkgdir/usr/share/applications/Etcher.desktop"
}