summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew McGinn2019-12-18 11:39:17 -0600
committerMatthew McGinn2019-12-27 14:03:49 -0500
commit06ecae6e47472abc2eb1b0124282bb405eefc3bc (patch)
treeccb8b1cb7ff6cf2327a233276aa4df2e1dbdb731
parent4709cd7bd0bd30a9cf92a1146fb66f9772eb60d1 (diff)
downloadaur-06ecae6e47472abc2eb1b0124282bb405eefc3bc.tar.gz
update version to v1.5.70
Signed-off-by: Matthew McGinn <mamcgi@gmail.com>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rwxr-xr-xbalena-etcher-electron2
3 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae23dac95cc0..0e8697d0bc0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = balena-etcher
pkgdesc = Flash OS images to SD cards & USB drives, safely and easily
- pkgver = 1.5.60
- pkgrel = 2
+ pkgver = 1.5.70
+ pkgrel = 1
epoch = 2
url = https://etcher.io
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = balena-etcher
makedepends = python2
makedepends = git
makedepends = jq
- depends = electron3-bin
+ depends = electron6
depends = gtk2
depends = libxtst
depends = libxss
@@ -24,7 +24,7 @@ pkgbase = balena-etcher
conflicts = etcher-git
conflicts = etcher-bin
options = !strip
- source = etcher::git+https://github.com/balena-io/etcher.git#tag=v1.5.60
+ source = etcher::git+https://github.com/balena-io/etcher.git#tag=v1.5.70
source = git+https://github.com/balena-io/scripts.git
source = balena-etcher-electron
source = balena-etcher-electron.desktop
diff --git a/PKGBUILD b/PKGBUILD
index 897e672a7663..48418bb330ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,15 @@
pkgname=balena-etcher
_pkgname=etcher
-pkgver=1.5.60
-pkgrel=2
+pkgver=1.5.70
+pkgrel=1
epoch=2
pkgdesc='Flash OS images to SD cards & USB drives, safely and easily'
arch=(x86_64)
_github_url='https://github.com/balena-io/etcher'
url='https://etcher.io'
license=(Apache)
-depends=(electron3-bin gtk2 libxtst libxss gconf nss alsa-lib nodejs)
+depends=(electron6 gtk2 libxtst libxss gconf nss alsa-lib nodejs)
makedepends=(npm python2 git jq)
optdepends=('libnotify: for notifications'
'speech-dispatcher: for text-to-speech')
@@ -28,7 +28,7 @@ source=("${_pkgname}::git+https://github.com/balena-io/${_pkgname}.git#tag=v${pk
)
sha256sums=('SKIP'
'SKIP'
- '135ce3deefb9f571b0a28abb7f6c678eea10546a537618b8a69c57012906a0eb'
+ '911cca26a477c0525085410c78cd9292dc4b6bd27fb7340034fe762d333a3f52'
'c950d9578f9cf60998c920bb60c6617559963f06a4918e7072fdc706b0ef5754')
prepare() {
@@ -41,8 +41,6 @@ prepare() {
build() {
cd "${_pkgname}"
export NPM_VERSION=$(npm --version)
- rm -rf node_modules
- find "${pkgdir}" -name package.json -print0 | xargs -r -0 sed -i '/_where/d'
make electron-develop
make webpack
npm prune --production
@@ -51,6 +49,7 @@ build() {
package() {
cd "${_pkgname}"
+ find "${pkgdir}" -name package.json -print0 | xargs -r -0 sed -i '/_where/d'
_appdir="${pkgdir}/usr/lib/${pkgname}"
install -d "${_appdir}"
diff --git a/balena-etcher-electron b/balena-etcher-electron
index 255b1b96cd1d..a65257d9157c 100755
--- a/balena-etcher-electron
+++ b/balena-etcher-electron
@@ -1,2 +1,2 @@
#!/usr/bin/sh
-exec electron3 /usr/lib/balena-etcher/lib/start.js "$@"
+exec electron6 /usr/lib/balena-etcher "$@"