summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew McGinn2019-07-30 14:56:06 +0100
committerMatthew McGinn2019-07-30 14:57:47 +0100
commit3bdc452e73d4629632d1ae0839b82d25a6c8ddbf (patch)
treea79421cf2451a9db4ed5949d65b3db15a8103a4c
parent63ac02e74179c81d2cfe868a4b8f5e395e3c213f (diff)
downloadaur-3bdc452e73d4629632d1ae0839b82d25a6c8ddbf.tar.gz
update version to v1.5.52
Signed-off-by: Matthew McGinn <mamcgi@gmail.com>
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
-rwxr-xr-xbalena-etcher-electron2
-rw-r--r--use-electron-4.1.5.patch52
4 files changed, 16 insertions, 71 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d102040e75f4..8e2ed307a5fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,7 @@
pkgbase = balena-etcher
pkgdesc = Flash OS images to SD cards & USB drives, safely and easily
- pkgver = 1.5.34
- pkgrel = 4
- epoch = 1
+ pkgver = 1.5.52
+ pkgrel = 3
url = https://etcher.io
arch = x86_64
license = Apache
@@ -10,29 +9,28 @@ pkgbase = balena-etcher
makedepends = python2
makedepends = git
makedepends = jq
- depends = electron4
+ depends = electron3-bin
depends = gtk2
depends = libxtst
depends = libxss
depends = gconf
depends = nss
depends = alsa-lib
+ depends = nodejs-lts-dubnium
optdepends = libnotify: for notifications
optdepends = speech-dispatcher: for text-to-speech
conflicts = etcher
conflicts = etcher-git
conflicts = etcher-bin
options = !strip
- source = etcher::git+https://github.com/balena-io/etcher.git#tag=v1.5.34
+ source = etcher::git+https://github.com/balena-io/etcher.git#tag=v1.5.52
source = git+https://github.com/balena-io/scripts.git
source = balena-etcher-electron
source = balena-etcher-electron.desktop
- source = use-electron-4.1.5.patch
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 76bfbcd018394ccf20e194950dbb5ad28d8f1dfc748be7802d3b499492017418
+ sha256sums = 135ce3deefb9f571b0a28abb7f6c678eea10546a537618b8a69c57012906a0eb
sha256sums = c950d9578f9cf60998c920bb60c6617559963f06a4918e7072fdc706b0ef5754
- sha256sums = 488e2ebce14bb9a8caaa1e9aaa73ee22c1c3eaa68c110d355bd588b37023f002
pkgname = balena-etcher
diff --git a/PKGBUILD b/PKGBUILD
index 1f902423d626..df9848fa3a9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,14 @@
pkgname=balena-etcher
_pkgname=etcher
-pkgver=1.5.34
-pkgrel=4
-epoch=1
+pkgver=1.5.52
+pkgrel=3
pkgdesc='Flash OS images to SD cards & USB drives, safely and easily'
arch=(x86_64)
_github_url='https://github.com/balena-io/etcher'
url='https://etcher.io'
license=(Apache)
-depends=('electron4' gtk2 libxtst libxss gconf nss alsa-lib)
+depends=(electron3-bin gtk2 libxtst libxss gconf nss alsa-lib nodejs-lts-dubnium)
makedepends=(npm python2 git jq)
optdepends=('libnotify: for notifications'
'speech-dispatcher: for text-to-speech')
@@ -25,12 +24,11 @@ source=("${_pkgname}::git+https://github.com/balena-io/${_pkgname}.git#tag=v${pk
'git+https://github.com/balena-io/scripts.git'
"${pkgname}-electron"
"${pkgname}-electron.desktop"
- "use-electron-4.1.5.patch")
+ )
sha256sums=('SKIP'
'SKIP'
- '76bfbcd018394ccf20e194950dbb5ad28d8f1dfc748be7802d3b499492017418'
- 'c950d9578f9cf60998c920bb60c6617559963f06a4918e7072fdc706b0ef5754'
- '488e2ebce14bb9a8caaa1e9aaa73ee22c1c3eaa68c110d355bd588b37023f002')
+ '135ce3deefb9f571b0a28abb7f6c678eea10546a537618b8a69c57012906a0eb'
+ 'c950d9578f9cf60998c920bb60c6617559963f06a4918e7072fdc706b0ef5754')
prepare() {
cd "${_pkgname}"
@@ -41,9 +39,10 @@ prepare() {
build() {
cd "${_pkgname}"
- #git apply -v "${srcdir}/use-electron-4.1.5.patch"
export NPM_VERSION=$(npm --version)
- make electron-develop #|| /bin/true
+ rm -rf node_modules
+ find "${pkgdir}" -name package.json -print0 | xargs -r -0 sed -i '/_where/d'
+ make electron-develop
make webpack
npm prune --production
}
diff --git a/balena-etcher-electron b/balena-etcher-electron
index 8ff7bf9fa9ad..255b1b96cd1d 100755
--- a/balena-etcher-electron
+++ b/balena-etcher-electron
@@ -1,2 +1,2 @@
#!/usr/bin/sh
-exec electron4 /usr/lib/balena-etcher/lib/start.js "$@"
+exec electron3 /usr/lib/balena-etcher/lib/start.js "$@"
diff --git a/use-electron-4.1.5.patch b/use-electron-4.1.5.patch
deleted file mode 100644
index 7c2b88278b39..000000000000
--- a/use-electron-4.1.5.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-diff --git a/npm-shrinkwrap.json b/npm-shrinkwrap.json
-index 6ce05035..6d7dbbd3 100644
---- a/npm-shrinkwrap.json
-+++ b/npm-shrinkwrap.json
-@@ -4169,20 +4169,20 @@
- "dev": true
- },
- "electron": {
-- "version": "3.1.9",
-- "resolved": "https://registry.npmjs.org/electron/-/electron-3.1.9.tgz",
-- "integrity": "sha512-F9AoMjY9zuQBdxmjZz644wHnJehNlYD+WQK2kBMXKoRKrzkYgD5k6QU6mqZuT5OGARpYp9zFOJ8uuJVcAB+TbQ==",
-+ "version": "4.1.5",
-+ "resolved": "https://registry.npmjs.org/electron/-/electron-4.1.5.tgz",
-+ "integrity": "sha512-0VZzUd4vZaUeSLdxJI/XMrMnPN7AROjPFZOiNgZZkYRUUEjGHfaSAbCJyxuXtii52KGhzGL0JgW0q5QmQ3ykKQ==",
- "dev": true,
- "requires": {
-- "@types/node": "^8.0.24",
-+ "@types/node": "^10.12.18",
- "electron-download": "^4.1.0",
- "extract-zip": "^1.0.3"
- },
- "dependencies": {
- "@types/node": {
-- "version": "8.10.48",
-- "resolved": "https://registry.npmjs.org/@types/node/-/node-8.10.48.tgz",
-- "integrity": "sha512-c35YEBTkL4rzXY2ucpSKy+UYHjUBIIkuJbWYbsGIrKLEWU5dgJMmLkkIb3qeC3O3Tpb1ZQCwecscvJTDjDjkRw==",
-+ "version": "10.14.5",
-+ "resolved": "https://registry.npmjs.org/@types/node/-/node-10.14.5.tgz",
-+ "integrity": "sha512-Ja7d4s0qyGFxjGeDq5S7Si25OFibSAHUi6i17UWnwNnpitADN7hah9q0Tl25gxuV5R1u2Bx+np6w4LHXfHyj/g==",
- "dev": true
- }
- }
-@@ -13956,4 +13956,4 @@
- }
- }
- }
--}
-+}
-\ No newline at end of file
-diff --git a/package.json b/package.json
-index babcc77a..eb84d9ef 100644
---- a/package.json
-+++ b/package.json
-@@ -89,7 +89,7 @@
- "angular-mocks": "1.7.6",
- "babel-loader": "^8.0.4",
- "chalk": "^1.1.3",
-- "electron": "3.1.9",
-+ "electron": "4.1.5",
- "electron-builder": "^20.40.2",
- "electron-mocha": "^6.0.4",
- "eslint": "^4.17.0",