summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhullyb2023-02-21 17:39:53 +0800
committerzhullyb2023-02-21 17:39:53 +0800
commit568ac4e5daed1e2166fd7b755b42b61d508a2c46 (patch)
tree493e941082336203ea94bba8695e042274fae5bd
parent4d6340aec8afa2097e1e82fbdefeb47381c35dc5 (diff)
downloadaur-568ac4e5daed1e2166fd7b755b42b61d508a2c46.tar.gz
upgpkg: balena-etcher@1.18.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rwxr-xr-xbalena-etcher-electron.sh4
3 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cedd4cbcae2f..004734221384 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = balena-etcher
pkgdesc = Flash OS images to SD cards & USB drives, safely and easily
- pkgver = 1.13.1
+ pkgver = 1.18.1
pkgrel = 1
epoch = 2
url = https://balena.io/etcher
@@ -11,7 +11,7 @@ pkgbase = balena-etcher
license = Apache
makedepends = npm
makedepends = nodejs
- depends = electron13
+ depends = electron19
depends = gtk3
depends = libxtst
depends = libxss
@@ -25,11 +25,11 @@ pkgbase = balena-etcher
conflicts = etcher-git
conflicts = etcher-bin
options = !strip
- source = etcher::git+https://github.com/balena-io/etcher.git#tag=v1.13.1
+ source = etcher::git+https://github.com/balena-io/etcher.git#tag=v1.18.1
source = balena-etcher-electron.sh
source = balena-etcher-electron.desktop
sha256sums = SKIP
- sha256sums = 7df90d90c8fd42ff9ef89f9e28c71381c52dec88b012984c015a534e0c1c2166
+ sha256sums = f6b04145e6173965c52c3cdb7ca13741f1c296d01fe9f5b787e3cb91c3259a6c
sha256sums = c950d9578f9cf60998c920bb60c6617559963f06a4918e7072fdc706b0ef5754
pkgname = balena-etcher
diff --git a/PKGBUILD b/PKGBUILD
index 5101846b05a3..924a7612ca40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=balena-etcher
_pkgname=etcher
-pkgver=1.13.1
+pkgver=1.18.1
pkgrel=1
epoch=2
pkgdesc='Flash OS images to SD cards & USB drives, safely and easily'
@@ -12,7 +12,7 @@ arch=('x86_64' 'i686' 'armv7h' 'aarch64')
_github_url='https://github.com/balena-io/etcher'
url='https://balena.io/etcher'
license=(Apache)
-depends=("electron13" "gtk3" "libxtst" "libxss" "nss" "alsa-lib" "glib2" "polkit" "libusb")
+depends=("electron19" "gtk3" "libxtst" "libxss" "nss" "alsa-lib" "glib2" "polkit" "libusb")
makedepends=("npm" "nodejs")
optdepends=("libnotify: for notifications")
conflicts=("${_pkgname}"
@@ -25,7 +25,7 @@ source=("etcher::git+https://github.com/balena-io/${_pkgname}.git#tag=v${pkgver}
"${pkgname}-electron.desktop"
)
sha256sums=('SKIP'
- '7df90d90c8fd42ff9ef89f9e28c71381c52dec88b012984c015a534e0c1c2166'
+ 'f6b04145e6173965c52c3cdb7ca13741f1c296d01fe9f5b787e3cb91c3259a6c'
'c950d9578f9cf60998c920bb60c6617559963f06a4918e7072fdc706b0ef5754')
prepare() {
diff --git a/balena-etcher-electron.sh b/balena-etcher-electron.sh
index 3b673d11d456..0517a8322692 100755
--- a/balena-etcher-electron.sh
+++ b/balena-etcher-electron.sh
@@ -1,6 +1,6 @@
#!/bin/bash
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron13 /usr/lib/balena-etcher "$@"
+ exec electron19 /usr/lib/balena-etcher "$@"
else
- exec electron13 --no-sandbox /usr/lib/balena-etcher "$@"
+ exec electron19 --no-sandbox /usr/lib/balena-etcher "$@"
fi