summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew McGinn2020-11-04 12:45:07 -0500
committerMatthew McGinn2020-11-04 12:45:07 -0500
commit7bfb51101651b1162ec4004fedf01ca0c393fe0a (patch)
tree9d9c6ab9d2c47ec1246ad2cac1917858d9dce8da
parentf9d3fa28ce8a4b56c665c4d00968825c2a4c9ee5 (diff)
downloadaur-7bfb51101651b1162ec4004fedf01ca0c393fe0a.tar.gz
make sure electron9 is being used
Signed-off-by: Matthew McGinn <mamcgi@gmail.com>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rwxr-xr-xbalena-etcher-electron.sh4
3 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5a193c2549f..4ef987db5e60 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = balena-etcher
pkgdesc = Flash OS images to SD cards & USB drives, safely and easily
pkgver = 1.5.109
- pkgrel = 1
+ pkgrel = 2
epoch = 2
url = https://balena.io/etcher
arch = x86_64
@@ -11,7 +11,7 @@ pkgbase = balena-etcher
makedepends = git
makedepends = jq
makedepends = patch
- depends = electron
+ depends = electron9
depends = gtk3
depends = libxtst
depends = libxss
diff --git a/PKGBUILD b/PKGBUILD
index a4c6802d04e5..8b8ed8964a6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,14 @@
pkgname=balena-etcher
_pkgname=etcher
pkgver=1.5.109
-pkgrel=1
+pkgrel=2
epoch=2
pkgdesc='Flash OS images to SD cards & USB drives, safely and easily'
arch=(x86_64)
_github_url='https://github.com/balena-io/etcher'
url='https://balena.io/etcher'
license=(Apache)
-depends=("electron" "gtk3" "libxtst" "libxss" "nss" "alsa-lib" "nodejs" "glib2" "polkit" "libusb")
+depends=("electron9" "gtk3" "libxtst" "libxss" "nss" "alsa-lib" "nodejs" "glib2" "polkit" "libusb")
makedepends=("npm" "python2" "git" "jq" "patch")
optdepends=("libnotify: for notifications")
conflicts=("${_pkgname}"
diff --git a/balena-etcher-electron.sh b/balena-etcher-electron.sh
index 20ac18aee82b..457c083c37a0 100755
--- a/balena-etcher-electron.sh
+++ b/balena-etcher-electron.sh
@@ -1,6 +1,6 @@
#!/bin/bash
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron /usr/lib/balena-etcher "$@"
+ exec electron9 /usr/lib/balena-etcher "$@"
else
- exec electron --no-sandbox /usr/lib/balena-etcher "$@"
+ exec electron9 --no-sandbox /usr/lib/balena-etcher "$@"
fi