summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhullyb2023-04-07 15:44:44 +0800
committerzhullyb2023-04-07 15:44:44 +0800
commit92167d9f3c58522e1a38efc6ff42a4dec514ca92 (patch)
tree3ef20422899e7e46136544e66098be81bf920ed5
parent6e718fc83ddaa96d5e58954e63925f8832425135 (diff)
downloadaur-92167d9f3c58522e1a38efc6ff42a4dec514ca92.tar.gz
upgpkg: balena-etcher@1.18.6
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD19
2 files changed, 20 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7089e43adae3..dbf7108759ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = balena-etcher
pkgdesc = Flash OS images to SD cards & USB drives, safely and easily
- pkgver = 1.18.3
+ pkgver = 1.18.6
pkgrel = 1
epoch = 2
url = https://balena.io/etcher
@@ -9,8 +9,7 @@ pkgbase = balena-etcher
arch = armv7h
arch = aarch64
license = Apache
- makedepends = npm
- makedepends = nodejs
+ makedepends = nvm
depends = electron19
depends = gtk3
depends = libxtst
@@ -25,7 +24,7 @@ pkgbase = balena-etcher
conflicts = etcher-git
conflicts = etcher-bin
options = !strip
- source = etcher::git+https://github.com/balena-io/etcher.git#tag=v1.18.3
+ source = etcher::git+https://github.com/balena-io/etcher.git#tag=v1.18.6
source = balena-etcher-electron.sh
source = balena-etcher-electron.desktop
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index c6b3d3e7636e..d834b7a937d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=balena-etcher
_pkgname=etcher
-pkgver=1.18.3
+pkgver=1.18.6
pkgrel=1
epoch=2
pkgdesc='Flash OS images to SD cards & USB drives, safely and easily'
@@ -13,7 +13,7 @@ _github_url='https://github.com/balena-io/etcher'
url='https://balena.io/etcher'
license=(Apache)
depends=("electron19" "gtk3" "libxtst" "libxss" "nss" "alsa-lib" "glib2" "polkit" "libusb")
-makedepends=("npm" "nodejs")
+makedepends=("nvm")
optdepends=("libnotify: for notifications")
conflicts=("${_pkgname}"
"${_pkgname}-git"
@@ -28,13 +28,28 @@ sha256sums=('SKIP'
'f6b04145e6173965c52c3cdb7ca13741f1c296d01fe9f5b787e3cb91c3259a6c'
'c950d9578f9cf60998c920bb60c6617559963f06a4918e7072fdc706b0ef5754')
+_ensure_local_nvm() {
+ # let's be sure we are starting clean
+ which nvm >/dev/null 2>&1 && nvm deactivate && nvm unload
+ export NVM_DIR="${srcdir}/.nvm"
+
+ # The init script returns 3 if version specified
+ # in ./.nvrc is not (yet) installed in $NVM_DIR
+ # but nvm itself still gets loaded ok
+ source /usr/share/nvm/init-nvm.sh || [[ $? != 1 ]]
+}
+
prepare() {
cd "${_pkgname}"
git submodule init
git submodule update || cd "${srcdir}/${_pkgname}/scripts/resin" && git checkout --
+ _ensure_local_nvm
+ nvm install 16
}
build() {
+ unset MAKEFLAGS # unset MAKEFLAGS to avoid some error
+ _ensure_local_nvm
cd "${_pkgname}"
npm ci --openssl_fips=""
npm run webpack