summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew McGinn2019-12-27 14:25:15 -0500
committerMatthew McGinn2019-12-27 14:25:15 -0500
commit966a34887c183d9d2feefc104df8c9e0ca033a4d (patch)
tree3edc024820686f10ed44fa08cc5eb0ce413b4a90
parent06ecae6e47472abc2eb1b0124282bb405eefc3bc (diff)
downloadaur-966a34887c183d9d2feefc104df8c9e0ca033a4d.tar.gz
properly clean up some references to srcdir
Signed-off-by: Matthew McGinn <mamcgi@gmail.com>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e8697d0bc0e..41bf95677e16 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = balena-etcher
pkgdesc = Flash OS images to SD cards & USB drives, safely and easily
pkgver = 1.5.70
- pkgrel = 1
+ pkgrel = 2
epoch = 2
url = https://etcher.io
arch = x86_64
@@ -24,13 +24,13 @@ pkgbase = balena-etcher
conflicts = etcher-git
conflicts = etcher-bin
options = !strip
- source = etcher::git+https://github.com/balena-io/etcher.git#tag=v1.5.70
+ source = https://github.com/balena-io/etcher/archive/v1.5.70.tar.gz
source = git+https://github.com/balena-io/scripts.git
source = balena-etcher-electron
source = balena-etcher-electron.desktop
+ sha256sums = 9c66bbbb709e70560cd831668de1d1aa6f581d647e6591c154edeff8474769c2
sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = 135ce3deefb9f571b0a28abb7f6c678eea10546a537618b8a69c57012906a0eb
+ sha256sums = 911cca26a477c0525085410c78cd9292dc4b6bd27fb7340034fe762d333a3f52
sha256sums = c950d9578f9cf60998c920bb60c6617559963f06a4918e7072fdc706b0ef5754
pkgname = balena-etcher
diff --git a/PKGBUILD b/PKGBUILD
index 48418bb330ec..f1b5b5b3f6d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=balena-etcher
_pkgname=etcher
pkgver=1.5.70
-pkgrel=1
+pkgrel=2
epoch=2
pkgdesc='Flash OS images to SD cards & USB drives, safely and easily'
arch=(x86_64)
@@ -21,12 +21,12 @@ conflicts=("${_pkgname}"
"${_pkgname}-bin"
)
options=('!strip')
-source=("${_pkgname}::git+https://github.com/balena-io/${_pkgname}.git#tag=v${pkgver}"
+source=("https://github.com/balena-io/${_pkgname}/archive/v${pkgver}.tar.gz"
'git+https://github.com/balena-io/scripts.git'
"${pkgname}-electron"
"${pkgname}-electron.desktop"
)
-sha256sums=('SKIP'
+sha256sums=('9c66bbbb709e70560cd831668de1d1aa6f581d647e6591c154edeff8474769c2'
'SKIP'
'911cca26a477c0525085410c78cd9292dc4b6bd27fb7340034fe762d333a3f52'
'c950d9578f9cf60998c920bb60c6617559963f06a4918e7072fdc706b0ef5754')
@@ -49,7 +49,6 @@ build() {
package() {
cd "${_pkgname}"
- find "${pkgdir}" -name package.json -print0 | xargs -r -0 sed -i '/_where/d'
_appdir="${pkgdir}/usr/lib/${pkgname}"
install -d "${_appdir}"
@@ -66,6 +65,8 @@ package() {
install -Dm644 "assets/iconset/${size}.png" \
"${pkgdir}/usr/share/icons/hicolor/${size}/apps/${pkgname}-electron.png"
done
+
+ find "${pkgdir}" -name package.json -print0 | xargs -r -0 sed -i '/_where/d'
}
# vim:set ts=2 sw=2 et: