summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew McGinn2019-06-05 18:17:04 +0100
committerMatthew McGinn2019-06-05 21:16:14 +0100
commite8742919ed63a2ee475f015dcf5c7a37f43cb7d5 (patch)
treebd25bf0efbed4160c5b3ad75b105fbd1f678ae74
parent430343f27af36ef9df8b83cc128aad698ff714dc (diff)
downloadaur-e8742919ed63a2ee475f015dcf5c7a37f43cb7d5.tar.gz
update version to v1.5.45
Signed-off-by: Matthew McGinn <mamcgi@gmail.com>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--use-electron-4.1.5.patch52
3 files changed, 63 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d6dd018301a..828f54adb2eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = balena-etcher
pkgdesc = Flash OS images to SD cards & USB drives, safely and easily
- pkgver = 1.5.34
+ pkgver = 1.5.45
pkgrel = 1
url = https://etcher.io
arch = x86_64
@@ -22,14 +22,16 @@ pkgbase = balena-etcher
conflicts = etcher-git
conflicts = etcher-bin
options = !strip
- source = etcher::git+https://github.com/balena-io/etcher.git#tag=v1.5.34
+ source = etcher::git+https://github.com/balena-io/etcher.git#tag=v1.5.45
source = git+https://github.com/balena-io/scripts.git
source = balena-etcher-electron
source = balena-etcher-electron.desktop
+ source = use-electron-4.1.5.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = 0a9de6e33cacdab09dfad84a0a7b6cd26e7f611e9473d1513eb49c53ac5d2edb
sha256sums = c950d9578f9cf60998c920bb60c6617559963f06a4918e7072fdc706b0ef5754
+ sha256sums = aeb8fdd102757c17ce63ea0c1445f9ca822ddf73e2e1c5f063c99e92ef7a78ca
pkgname = balena-etcher
diff --git a/PKGBUILD b/PKGBUILD
index 76dc45974de8..6d17077421ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=balena-etcher
_pkgname=etcher
-pkgver=1.5.34
+pkgver=1.5.45
pkgrel=1
pkgdesc='Flash OS images to SD cards & USB drives, safely and easily'
arch=(x86_64)
@@ -22,11 +22,13 @@ options=('!strip')
source=("${_pkgname}::git+https://github.com/balena-io/${_pkgname}.git#tag=v${pkgver}"
'git+https://github.com/balena-io/scripts.git'
"${pkgname}-electron"
- "${pkgname}-electron.desktop")
+ "${pkgname}-electron.desktop"
+ "use-electron-4.1.5.patch")
sha256sums=('SKIP'
'SKIP'
'0a9de6e33cacdab09dfad84a0a7b6cd26e7f611e9473d1513eb49c53ac5d2edb'
- 'c950d9578f9cf60998c920bb60c6617559963f06a4918e7072fdc706b0ef5754')
+ 'c950d9578f9cf60998c920bb60c6617559963f06a4918e7072fdc706b0ef5754'
+ '488e2ebce14bb9a8caaa1e9aaa73ee22c1c3eaa68c110d355bd588b37023f002')
prepare() {
cd "${_pkgname}"
@@ -37,8 +39,9 @@ prepare() {
build() {
cd "${_pkgname}"
+ git apply -v "${srcdir}/use-electron-4.1.5.patch"
export NPM_VERSION=$(npm --version)
- make electron-develop
+ make electron-develop || /bin/true
make webpack
npm prune --production
}
diff --git a/use-electron-4.1.5.patch b/use-electron-4.1.5.patch
new file mode 100644
index 000000000000..7c2b88278b39
--- /dev/null
+++ b/use-electron-4.1.5.patch
@@ -0,0 +1,52 @@
+diff --git a/npm-shrinkwrap.json b/npm-shrinkwrap.json
+index 6ce05035..6d7dbbd3 100644
+--- a/npm-shrinkwrap.json
++++ b/npm-shrinkwrap.json
+@@ -4169,20 +4169,20 @@
+ "dev": true
+ },
+ "electron": {
+- "version": "3.1.9",
+- "resolved": "https://registry.npmjs.org/electron/-/electron-3.1.9.tgz",
+- "integrity": "sha512-F9AoMjY9zuQBdxmjZz644wHnJehNlYD+WQK2kBMXKoRKrzkYgD5k6QU6mqZuT5OGARpYp9zFOJ8uuJVcAB+TbQ==",
++ "version": "4.1.5",
++ "resolved": "https://registry.npmjs.org/electron/-/electron-4.1.5.tgz",
++ "integrity": "sha512-0VZzUd4vZaUeSLdxJI/XMrMnPN7AROjPFZOiNgZZkYRUUEjGHfaSAbCJyxuXtii52KGhzGL0JgW0q5QmQ3ykKQ==",
+ "dev": true,
+ "requires": {
+- "@types/node": "^8.0.24",
++ "@types/node": "^10.12.18",
+ "electron-download": "^4.1.0",
+ "extract-zip": "^1.0.3"
+ },
+ "dependencies": {
+ "@types/node": {
+- "version": "8.10.48",
+- "resolved": "https://registry.npmjs.org/@types/node/-/node-8.10.48.tgz",
+- "integrity": "sha512-c35YEBTkL4rzXY2ucpSKy+UYHjUBIIkuJbWYbsGIrKLEWU5dgJMmLkkIb3qeC3O3Tpb1ZQCwecscvJTDjDjkRw==",
++ "version": "10.14.5",
++ "resolved": "https://registry.npmjs.org/@types/node/-/node-10.14.5.tgz",
++ "integrity": "sha512-Ja7d4s0qyGFxjGeDq5S7Si25OFibSAHUi6i17UWnwNnpitADN7hah9q0Tl25gxuV5R1u2Bx+np6w4LHXfHyj/g==",
+ "dev": true
+ }
+ }
+@@ -13956,4 +13956,4 @@
+ }
+ }
+ }
+-}
++}
+\ No newline at end of file
+diff --git a/package.json b/package.json
+index babcc77a..eb84d9ef 100644
+--- a/package.json
++++ b/package.json
+@@ -89,7 +89,7 @@
+ "angular-mocks": "1.7.6",
+ "babel-loader": "^8.0.4",
+ "chalk": "^1.1.3",
+- "electron": "3.1.9",
++ "electron": "4.1.5",
+ "electron-builder": "^20.40.2",
+ "electron-mocha": "^6.0.4",
+ "eslint": "^4.17.0",