summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Baag2017-04-21 20:09:51 +0200
committerThomas Baag2017-04-21 20:09:51 +0200
commit5a5372235a564566eb5207c481a6f967f81eb177 (patch)
treeebef9a09150f664f5d92216c79469f44324ee5e5
parent87dfc4714a3bfb2b8122e7ec9002453a4a933a05 (diff)
downloadaur-5a5372235a564566eb5207c481a6f967f81eb177.tar.gz
added desktop and appdata file
-rw-r--r--PKGBUILD17
-rw-r--r--ballerburg.appdata.xml27
-rw-r--r--ballerburg.desktop10
3 files changed, 51 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 719adfd59464..7f970970b9cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Thomas Baag <aur@spam.b2ag.de>
pkgname=ballerburg
pkgver=1.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="Classical castle combat game"
arch=(i686 x86_64)
url="http://baller.tuxfamily.org/"
@@ -17,9 +17,13 @@ backup=()
options=()
install=
changelog=
-source=(http://download.tuxfamily.org/baller/$pkgname-$pkgver.tar.gz)
+source=(http://download.tuxfamily.org/baller/$pkgname-$pkgver.tar.gz
+ ballerburg.appdata.xml
+ ballerburg.desktop)
noextract=()
-md5sums=('ad8beb770dfa151a8c171a6beecf5a44')
+md5sums=('ad8beb770dfa151a8c171a6beecf5a44'
+ 'd4734cd1b9a46f8a6c356588c5bbfac8'
+ 'f7b972e721655e3da7b69c9c5bc224d4')
build() {
cd "$pkgname-$pkgver"
@@ -32,4 +36,11 @@ package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
+
+ cd ..
+
+ mkdir -p "$pkgdir/usr/share/appdata"
+ cp ballerburg.appdata.xml "$pkgdir/usr/share/appdata"
+ mkdir -p "$pkgdir/usr/share/applications"
+ cp ballerburg.desktop "$pkgdir/usr/share/applications"
}
diff --git a/ballerburg.appdata.xml b/ballerburg.appdata.xml
new file mode 100644
index 000000000000..3fd321224e55
--- /dev/null
+++ b/ballerburg.appdata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!-- Copyright 2015 Andrea Musuruane <musuruan@gmail.com> -->
+<application>
+ <id type="desktop">ballerburg.desktop</id>
+ <metadata_license>CC0-1.0</metadata_license>
+ <project_license>GPLv3+</project_license>
+ <name>Ballerburg</name>
+ <summary>Two players, two castles, and a hill in between</summary>
+ <description>
+ <p>
+ Two castles, separated by a mountain, try to defeat each other with their
+ cannonballs, either by killing the opponent's king or by weakening the
+ opponent enough so that the king capitulates.
+ </p>
+ <p>
+ Ballerburg was originally written 1987 by Eckhard Kruse, for the Atari ST
+ machines (which were brand new computers at that point in time). Over 25
+ years later, here's finally the adaption of the original source code to
+ modern operating systems.
+ </p>
+ </description>
+ <url type="homepage">http://baller.tuxfamily.org/</url>
+ <screenshots>
+ <screenshot type="default">http://baller.tuxfamily.org/screenshot1.png</screenshot>
+ <screenshot>http://baller.tuxfamily.org/screenshot2.png</screenshot>
+ </screenshots>
+</application>
diff --git a/ballerburg.desktop b/ballerburg.desktop
new file mode 100644
index 000000000000..bccb32f0c2c5
--- /dev/null
+++ b/ballerburg.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Ballerburg
+Comment=Two players, two castles, and a hill in between
+Exec=ballerburg
+Icon=ballerburg
+Terminal=false
+Type=Application
+Categories=Game;StrategyGame;
+
+X-Desktop-File-Install-Version=0.22